使用MSTP+VRRP+默认路由+静态路由+子网划分+dhcp实验案例 实验环境_封装

IOU1上面vlan  ip地址

vlan 10 192.168.10.60 gw:192.168.10.62

vlan 11 192.168.10.124 gw:192.168.10.126

vlan 12 192.168.10.188 gw:192.168.10.190

vlan 13 192.168.10.252 gw:192.168.10.254

IOU2上面vlan  ip地址

vlan 10 192.168.10.61 gw:192.168.10.62

vlan 11 192.168.10.125 gw:192.168.10.126

vlan 12 192.168.10.189 gw:192.168.10.190

vlan 13 192.168.10.253 gw:192.168.10.254

实验步骤:

使用encapsulation dot1q进行封装

(IOU2和3都需要封装)

IOU1(config)#interface range ethernet 0/0-2

IOU1(config-if-range)#switchport trunk encapsulation dot1q

IOU1(config-if-range)#switchport mode trunk

 

将IOU1和IOU2的0/0-1接口进行封装

IOU1(config)#interface range ethernet 0/0-1

IOU1(config-if-range)#channel-group 1 mode on

IOU1(config-if-range)#ex   

IOU1(config)#interface port-channel 1

IOU1(config-if)#switchport trunk encapsulation dot1q

IOU1(config-if)#switchport mode trunk

 

配置mstp

(IOU1和IOU2也需配置)

IOU4(config)#spanning-tree mode mst

IOU4(config)#spanning-tree mst configuration

IOU4(config-mst)#name cisco

IOU4(config-mst)#revision 1

IOU4(config-mst)#instance 1 vlan 10,11

IOU4(config-mst)#instance 2 vlan 12,13

由下图可以看出vlan10,11已加入mst 1   vlan12,13已加入mst 2

使用MSTP+VRRP+默认路由+静态路由+子网划分+dhcp实验案例 实验环境_静态路由_02


配置生成树

(只在IOU1,2上面配置IOU2相反)

IOU1(config)#spanning-tree mst 1 root primary    

IOU1(config)#spanning-tree mst 2 root secondary

使用MSTP+VRRP+默认路由+静态路由+子网划分+dhcp实验案例 实验环境_静态路由_03


配置vrrp和接口跟踪

(IOU2命令相反)

IOU1(config-if)#exit

IOU1(config)#track 100 interface ethernet 0/3 line-protocol

IOU1(config-track)#exit

IOU1(config)#interface vlan 10

IOU1(config-if)#vrrp 10 track 100 decrement 30

IOU1(config-if)#exit

IOU1(config)#interface vlan 11

IOU1(config-if)#ip address 192.168.10.124 255.255.255.192

IOU1(config-if)#vrrp 11 ip 192.168.10.126

IOU1(config-if)#vrrp 11 priority 110                             //设置优先级为110

IOU1(config-if)#vrrp 11 preempt

IOU1(config-if)#vrrp 11 track 100 decrement 30

IOU1(config-if)#no shutdown

IOU1(config)#interface vlan 12

IOU1(config-if)#ip address 192.168.10.188 255.255.255.192

IOU1(config-if)#vrrp 12 ip 192.168.10.190

IOU1(config-if)#vrrp 12 priority 90                                  //优先级为90

IOU1(config-if)#vrrp 12 preempt

IOU1(config-if)#no shutdown

IOU1(config-if)#ex

IOU1(config)#interface vlan 13

IOU1(config-if)#ip address 192.168.10.252 255.255.255.192

IOU1(config-if)#vrrp 13 ip 192.168.10.254

IOU1(config-if)#vrrp 13 priority 90

IOU1(config-if)#vrrp 13 preempt

IOU1(config-if)#ex

配置上联端口

(iou2也需配置)

IOU1(config)#interface ethernet 0/3

IOU1(config-if)#no switchport

IOU1(config-if)#ip address 172.16.1.1 255.255.255.0

IOU1(config-if)#no shutdown

在路由器上配置IP地址

IOU3(config)#interface ethernet 0/0

IOU3(config-if)#duplex full                                       //配置全双工

IOU3(config-if)#ip address 172.16.1.2 255.255.255.0

IOU3(config-if)#no shutdown

IOU3(config-if)#ex

IOU3(config)#interface ethernet 0/1

IOU3(config-if)#duplex full

IOU3(config-if)#ip address 172.16.2.2 255.255.255.0

IOU3(config-if)#no shutdown

IOU3(config-if)#ex

IOU3(config)#interface loopback 0

IOU3(config-if)#ip address 1.1.1.1 255.255.255.255

IOU3(config-if)#no shutdown

配置默认路由

IOU1(config-if)#ip route 0.0.0.0 0.0.0.0 172.16.1.2

使用MSTP+VRRP+默认路由+静态路由+子网划分+dhcp实验案例 实验环境_封装_04

在路由器上配置静态路由实现全网互通

IOU3(config)#ip route 192.168.10.0 255.255.255.128 172.16.1.1

IOU3(config)#ip route 192.168.10.0 255.255.255.128 172.16.2.1 11      //隐藏这断静态路由

IOU3(config)#ip route 192.168.10.128 255.255.255.128 172.16.1.1 11

IOU3(config)#ip route 192.168.10.128 255.255.255.128 172.16.2.1

使用MSTP+VRRP+默认路由+静态路由+子网划分+dhcp实验案例 实验环境_ip地址_05


在路由器上配置dhcp

IOU3(config)#ip dhcp pool vlan10

IOU3(dhcp-config)#network 192.168.10.0 /26

IOU3(dhcp-config)#default-router 192.168.10.62

IOU3(dhcp-config)#dns-server 8.8.8.8

IOU3(dhcp-config)#ex

IOU3(config)#ip dhcp pool vlan11

IOU3(dhcp-config)#network 192.168.10.64 /26

IOU3(dhcp-config)#default-router 192.168.10.126

IOU3(dhcp-config)#dns-server 8.8.8.8

IOU3(dhcp-config)#ex    

IOU3(config)#ip dhcp pool vlan12

IOU3(dhcp-config)#network 192.168.10.128 /26

IOU3(dhcp-config)#default-router 192.168.10.190

IOU3(dhcp-config)#dns-server 8.8.8.8

IOU3(dhcp-config)#ex

IOU3(config)#ip dhcp pool vlan13

IOU3(dhcp-config)#network 192.168.10.192 /26

IOU3(dhcp-config)#default-router 192.168.10.254

IOU3(dhcp-config)#dns-server 8.8.8.8

配置dhcp中继

(IOU1,2都需配置)

IOU2(config-if)#ip helper-address 1.1.1.1

IOU2(config-if)#interface vlan 11        

IOU2(config-if)#ip helper-address 1.1.1.1

IOU2(config-if)#interface vlan 12        

IOU2(config-if)#ip helper-address 1.1.1.1

IOU2(config-if)#interface vlan 13        

IOU2(config-if)#ip helper-address 1.1.1.1

将接口加入vlan

IOU4(config)#interface ethernet 0/2  

IOU4(config-if)#switchport mode access

IOU4(config-if)#switchport access vlan 10

IOU4(config-if)#ex

IOU4(config)#interface ethernet 0/3

IOU4(config-if)#switchport mode access

IOU4(config-if)#switchport access vlan 11

IOU4(config-if)#ex    

IOU4(config)#interface ethernet 1/0

IOU4(config-if)#switchport mode access

IOU4(config-if)#switchport access vlan 12

IOU4(config-if)#ex

IOU4(config)#interface ethernet 1/1

IOU4(config-if)#switchport mode access

IOU4(config-if)#switchport access vlan 13

使用dhcp获取ip地址

IOU5(config)#interface ethernet 0/0

IOU5(config-if)#duplex full

IOU5(config-if)#ip address dhcp

IOU5(config-if)#no shutdown

使用MSTP+VRRP+默认路由+静态路由+子网划分+dhcp实验案例 实验环境_ip地址_06

配置完成使用ping命令查看能否ping通

使用MSTP+VRRP+默认路由+静态路由+子网划分+dhcp实验案例 实验环境_ip地址_07