实验需求

实验使用网段192.168.10.0/24分配IP地址,划分vlan 10~13,每个vlan不超过50台主机,配置MSTP协议实现负载均衡、配置VRRP协议实现网关备份,使用静态路由实现全网互通,在路由器上配置DHCP分发IP地址

实验目的

1、掌握子网划分

2、掌握MSTP协议配置及使用场景

3、掌握VRRP协议配置及使用场景

4、掌握DHCP服务器及中继配置

5、掌握静态路由器的配置及使用场景

实验拓扑

MSTP+VRRP+静态路由+子网划分+DHCP实验案例 _使用场景

1、交换机之间配置干道

IOU2上的配置

IOU2(config)#interface range ethernet 0/0-2
IOU2(config-if-range)#switchport trunk encapsulation dot1q
IOU2(config-if-range)#switchport mode trunk
IOU2(config-if-range)#exit

IOU2(config)#interface range ethernet 0/0-1
Creating a port-channel interface Port-channel 1
IOU2(config-if-range)#exit

IOU2(config)#interface port-channel 1
IOU2(config-if)#switchport trunk encapsulation dot1q
IOU2(config-if)#switchport mode trunk
IOU2(config-if)#exit

IOU3上的配置与IOU2上的配置大致一致

IOU3(config)#interface range ethernet 0/0-2
IOU3(config-if-range)#switchport trunk encapsulation dot1q
IOU3(config-if-range)#switchport mode trunk
IOU3(config-if-range)#exit

IOU3(config)#interface range ethernet 0/0-1
Creating a port-channel interface Port-channel 1
IOU3(config-if-range)#exit

IOU3(config)#interface port-channel 1
IOU3(config-if)#switchport trunk encapsulation dot1q
IOU3(config-if)#switchport mode trunk
IOU3(config-if)#exit

IOU4上的配置

IOU4(config)#interface range ethernet 0/0-1
IOU4(config-if-range)#switchport trunk encapsulation dot1q
IOU4(config-if-range)#switchport mode trunk
IOU4(config-if-range)#exit


2、交换机创建vlan

IOU2上的配置

IOU2(config)#vlan 10-13
IOU2(config-vlan)#exit

IOU3上的配置

IOU2(config)#vlan 10-13
IOU2(config-vlan)#exit

IOU4上的配置

IOU2(config)#vlan 10-13
IOU2(config-vlan)#exit


3、配置MSTP多生成树协议

IOU2上的配置

IOU2(config)#spanning-tree mode mst 
IOU2(config)#spanning-tree mst configuration
IOU2(config-mst)#name cisco
IOU2(config-mst)#revision 1
IOU2(config-mst)#instance 1 vlan 10,11
IOU2(config-mst)#instance 2 vlan 12,13
IOU2(config-mst)#exit

IOU3上的配置

IOU3(config)#spanning-tree mode mst 
IOU3(config)#spanning-tree mst configuration
IOU3(config-mst)#name cisco
IOU3(config-mst)#revision 1
IOU3(config-mst)#instance 1 vlan 10,11
IOU3(config-mst)#instance 2 vlan 12,13
IOU3(config-mst)#exit

IOU4上的配置

IOU4(config)#spanning-tree mode mst 
IOU4(config)#spanning-tree mst configuration
IOU4(config-mst)#name cisco
IOU4(config-mst)#revision 1
IOU4(config-mst)#instance 1 vlan 10,11
IOU4(config-mst)#instance 2 vlan 12,13
IOU4(config-mst)#exit

在接入层交换机使用show spanning tree mst 1查看配置结果

发现没有实现负载分担,接下来需要在IOU2及IOU3上配置各个实例的根桥

IOU2上的配置

IOU2(config)#spanning-tree mst  1 root primary 
IOU2(config)#spanning-tree mst 2 root secondary

IOU3上的配置

IOU2(config)#spanning-tree mst  1 root secondary 
IOU2(config)#spanning-tree mst 2 root ary


4、配置VRRP

IOU2上的配置

IOU2(config)#track 100 interface ethernet 0/3 line-protocol 
IOU2(config-track)#ex

IOU2(config)#interface vlan 10
IOU2(config-if)#ip address 192.168.10.60 255.255.255.192
IOU2(config-if)#vrrp 10 ip 192.168.10.62
IOU2(config-if)#vrrp 10 priority 110
IOU2(config-if)#vrrp 10 preempt
IOU2(config-if)#no shutdown
IOU2(config-if)#vrrp 10 track 100 decrement 30
IOU2(config-if)#exit

IOU2(config)#interface vlan 11
IOU2(config-if)#ip address 192.168.10.124 255.255.255.192
IOU2(config-if)#vrrp 11 ip 192.168.10.126
IOU2(config-if)#vrrp 11 priority 110
IOU2(config-if)#vrrp 11 preempt
IOU2(config-if)#vrrp 11 track 100 decrement 30
IOU2(config-if)#no shutdown
IOU2(config-if)#exit

IOU2(config)#interface vlan 12
IOU2(config-if)#ip address 192.168.10.188 255.255.255.192
IOU2(config-if)#vrrp 12 ip 192.168.10.190
IOU2(config-if)#vrrp 12 priority 90
IOU2(config-if)#vrrp 12 preempt
IOU2(config-if)#no shutdown
IOU2(config-if)#ex

IOU2(config)#interface vlan 13
IOU2(config-if)#ip address 192.168.10.252 255.255.255.192
IOU2(config-if)#vrrp 13 ip 192.168.10.254
IOU2(config-if)#vrrp 13 priority 90
IOU2(config-if)#vrrp 13 preempt
IOU2(config-if)#no shutdown
IOU2(config-if)#ex

IOU3上的配置

IOU3(config)#track 100 interface ethernet 0/3 line-protocol 
IOU3(config-track)#ex

IOU3(config)#interface vlan 10
IOU3(config-if)#ip address 192.168.10.61255.255.255.192
IOU3(config-if)#vrrp 10 ip 192.168.10.62
IOU3(config-if)#vrrp 10 priority 90
IOU3(config-if)#vrrp 10 preempt
IOU3(config-if)#no shutdown
IOU3(config-if)#exit

IOU3(config)#interface vlan 11
IOU3(config-if)#ip address 192.168.10.124 255.255.255.192
IOU3(config-if)#vrrp 11 ip 192.168.10.126
IOU3(config-if)#vrrp 11 priority 90
IOU3(config-if)#vrrp 11 preempt
IOU3(config-if)#no shutdown
IOU3(config-if)#exit

IOU3(config)#interface vlan 12
IOU3(config-if)#ip address 192.168.10.188 255.255.255.192
IOU3(config-if)#vrrp 12 ip 192.168.10.190
IOU3(config-if)#vrrp 12 priority 110
IOU3(config-if)#vrrp 12 preempt
IOU3(config-if)#vrrp 12 track 100 decrement 30
IOU3(config-if)#no shutdown
IOU3(config-if)#ex

IOU3(config)#interface vlan 13
IOU3(config-if)#ip address 192.168.10.252 255.255.255.192
IOU3(config-if)#vrrp 13 ip 192.168.10.254
IOU3(config-if)#vrrp 13 priority 110
IOU3(config-if)#vrrp 13 preempt
IOU3(config-if)#vrrp 13 track 100 decrement 30
IOU3(config-if)#no shutdown
IOU3(config-if)#ex


5、网络设备配置IP地址

IOU2上的配置

IOU2(config)#interface ethernet 0/3
IOU2(config-if)#no switchport
IOU2(config-if)#ip address 172.16.1.1 255.255.255.0
IOU2(config-if)#no shutdown

IOU3上的配置

IOU3(config)#interface ethernet 0/3
IOU3(config-if)#no switchport
IOU3(config-if)#ip address 172.16.2.1 255.255.255.0
IOU3(config-if)#no shutdown
IOU3(config-if)#ex

IOU4上的配置

IOU1(config)#interface ethernet 0/0
IOU1(config-if)#duplex full
IOU1(config-if)#ip address 172.16.1.2 255.255.255.0
IOU1(config-if)#no shutdown
IOU1(config-if)#ex

IOU1(config)#interface ethernet 0/1
IOU1(config-if)#ip address 172.16.2.2 255.255.255.0
IOU1(config-if)#duplex full
IOU1(config-if)#no shutdown
IOU1(config-if)#exit

IOU1(config)#interface loopback 0
IOU1(config-if)#ip address 1.1.1.1 255.255.255.255
IOU1(config-if)#no shutdown
IOU1(config-if)#exit


6、配置静态路由

IOU2上的配置

IOU2(config)#ip route 0.0.0.0 0.0.0.0 172.16.1.2

IOU3上的配置

IOU3(config)#ip route 0.0.0.0 0.0.0.0 172.16.2.2

IOU1上的配置,使用了汇总路由及浮动静态路由的配置

IOU1(config)#ip route 192.168.10.0 255.255.255.128 172.16.1.1
IOU1(config)#ip route 192.168.10.128 255.255.255.128 172.16.2.1
IOU1(config)#ip route 192.168.10.0 255.255.255.128 172.16.2.1 11
IOU1(config)#ip route 192.168.10.128 255.255.255.128 172.16.1.1 11


7、配置DHCP服务

在IOU1上配置DHCP服务器

IOU1(config)#ip dhcp pool vlan10
IOU1(dhcp-config)#network 192.168.10.0 /26
IOU1(dhcp-config)#default-router 192.168.10.62
IOU1(dhcp-config)#dns-server 8.8.8.8
IOU1(dhcp-config)#exit

IOU1(config)#ip dhcp pool vlan11
IOU1(dhcp-config)#network 192.168.10.64 /26
IOU1(dhcp-config)#default-router 192.168.10.126
IOU1(dhcp-config)#dns-server 8.8.8.8
IOU1(dhcp-config)#exit

IOU1(config)#ip dhcp pool vlan12
IOU1(dhcp-config)#network 192.168.10.128 /26
IOU1(dhcp-config)#default-router 192.168.10.190
IOU1(dhcp-config)#dns-server 8.8.8.8
IOU1(dhcp-config)#exit

IOU1(config)#ip dhcp pool vlan13
IOU1(dhcp-config)#network 192.168.10.192 /26
IOU1(dhcp-config)#default-router 192.168.10.254
IOU1(dhcp-config)#dns-server 8.8.8.8
IOU1(dhcp-config)#exit

在IOU2上配置DHCP中继

IOU2(config)#interface vlan 10         
IOU2(config-if)#ip helper-address 1.1.1.1
IOU2(config-if)#exit

IOU2(config)#interface vlan 11
IOU2(config-if)#ip helper-address 1.1.1.1
IOU2(config-if)#exit

IOU2(config)#interface vlan 12
IOU2(config-if)#ip helper-address 1.1.1.1
IOU2(config-if)#exit

IOU2(config)#interface vlan 13
IOU2(config-if)#ip helper-address 1.1.1.1
IOU2(config-if)#exit

在IOU3上配置DHCP中继

IOU3(config)#interface vlan 10         
IOU3(config-if)#ip helper-address 1.1.1.1
IOU3(config-if)#exit

IOU3(config)#interface vlan 11
IOU3(config-if)#ip helper-address 1.1.1.1
IOU3(config-if)#exit

IOU3(config)#interface vlan 12
IOU3(config-if)#ip helper-address 1.1.1.1
IOU3(config-if)#exit

IOU3(config)#interface vlan 13
IOU3(config-if)#ip helper-address 1.1.1.1
IOU3(config-if)#exit


在PC上使用ping命令测试网络连通性MSTP+VRRP+静态路由+子网划分+DHCP实验案例 _使用场景_02