实验目的

1、掌握子网划分

2、掌握MSTP协议配置

3、掌握VRRP协议配置

4、掌握DHCP服务器及中继配置

5、掌握静态路由器的配置

Cisco使用MSTP+VRRP+静态路由+子网划分+DHCP综合案例_服务器

IOU1

e0/0:172.16.1.2/24


e0/1:172.16.2.2/24


loo0:1.1.1.1/32


IOU2

vlanif10:192.168.10.60/26

vip:192.168.10.62

vlanif20:192.168.10.124/24

vip:192.168.10.126

vlanif30:192.168.10.188/24

vip:192.168.10.190

vlanif40:192.168.10.252/24

vip:192.168.10.254

IOU3

vlanif10:192.168.10.61/26

vip:192.168.10.62

vlanif20:192.168.10.125/24

vip:192.168.10.126

vlanif30:192.168.10.189/24

vip:192.168.10.190

vlanif40:192.168.10.253/24

vip:192.168.10.254


IOU2的配置

配置步骤三层交换之间配置封装和干道

IOU2(config)#interface range ethernet 0/1-3

IOU2(config-if-range)#switchport trunk encapsulation dot1q  

IOU2(config-if-range)#switchport mode trunk 

IOU2(config-if-range)#exit

配置以太网通道

IOU2(config)#interface range ethernet 0/1-2

Creating a port-channel interface Port-channel 1

IOU2(config-if-range)#exit

IOU2(config)#interface port-channel 1

IOU2(config-if)#switchport trunk encapsulation dot1q  

IOU2(config-if)#switchport mode trunk  

IOU2(config-if)#end

Cisco使用MSTP+VRRP+静态路由+子网划分+DHCP综合案例_服务器_02

使用show interface trunk可以查看结果,可以看到Et0/2以及Po1接口均已成功配置为干道模式


IOU3配置

IOU3上的配置与IOU2上的配置大致一致

IOU3(config)#interface range ethernet 0/1-3

IOU3(config-if-range)#switchport trunk encapsulation dot1q  

IOU3(config-if-range)#switchport mode trunk  

IOU3(config-if-range)#exit

配置以太网通道

IOU3(config)#interface range ethernet 0/1-2

Creating a port-channel interface Port-channel 1

IOU3(config-if-range)#exit

IOU3(config)#interface port-channel 1

IOU3(config-if)#switchport trunk encapsulation dot1q

IOU3(config-if)#switchport mode trunk

IOU3(config-if)#exit

Cisco使用MSTP+VRRP+静态路由+子网划分+DHCP综合案例_服务器_03

使用show interface trunk可以查看到配置结果与需求一致

交换机之间创建VLAN

IOU2上的配置

IOU2(config)#vlan 10,20,30,40

IOU2(config-vlan)#exit


IOU3上的配置

IOU3(config)#vlan 10,20,30,40

IOU3(config-vlan)#exi


IOU4上的配置

IOU4(config)#vlan 10,20,30,40

IOU4(config-vlan)#exit

使用show vlan 可以查看

Cisco使用MSTP+VRRP+静态路由+子网划分+DHCP综合案例_静态路由_04


配置MSTP多生成树协议

IOU2,3,4的配置命令一致

IOU2(config)#spanning-tree mode mst  

IOU2(config)#spanning-tree mst configuration  

IOU2(config-mst)#name 1

IOU2(config-mst)#revision 1

IOU2(config-mst)#instance 1 vlan 10,20

IOU2(config-mst)#instance 2 vlan 30,40

IOU2(config-mst)#exit

在接入层交换机使用show spanning tree mst 1查看配置

Cisco使用MSTP+VRRP+静态路由+子网划分+DHCP综合案例_路由表_05

配置VRRP

IOU2的配置

IOU2(config)#track 100 interface ethernet 0/3 line-protocol  

IOU2(config-track)#ex

IOU2(config)#interface vlan 10

IOU2(config-if)#ip address 192.168.10.60 255.255.255.192

IOU2(config-if)#vrrp 10 ip 192.168.10.62

IOU2(config-if)#vrrp 10 priority 110

IOU2(config-if)#vrrp 10 preempt  

IOU2(config-if)#no shutdown  

IOU2(config-if)#vrrp 10 track 100 decrement 30

IOU2(config-if)#exit

IOU2(config)#

IOU2(config)#

IOU2(config)#interface vlan 20              

IOU2(config-if)#ip address 192.168.10.124 255.255.255.192

IOU2(config-if)#vrrp 20 ip 192.168.10.126

IOU2(config-if)#vrrp 20 priority 110

IOU2(config-if)#vrrp 20 preempt  

IOU2(config-if)#vrrp 20 track 100 decrement 30

IOU2(config-if)#no shutdown  

IOU2(config-if)#exit

IOU2(config)#

IOU2(config)#interface vlan 30

IOU2(config-if)#ip address 192.168.10.188 255.255.255.192

IOU2(config-if)#vrrp 30 ip 192.168.10.190

IOU2(config-if)#vrrp 30 priority 90

IOU2(config-if)#vrrp 30 preempt  

IOU2(config-if)#no shutdown  

IOU2(config-if)#ex

IOU2(config)#

IOU2(config)#interface vlan 40                        

IOU2(config-if)#ip address 192.168.10.252 255.255.255.192

IOU2(config-if)#vrrp 40 ip 192.168.10.254  

IOU2(config-if)#vrrp 40 priority 90  

IOU2(config-if)#vrrp 40 preempt  

IOU2(config-if)#no shutdown  

IOU2(config-if)#ex


IOU3上的配置

IOU3(config)#track 100 interface ethernet 0/3 line-protocol  

IOU3(config-track)#ex

IOU3(config)#

IOU3(config)#interface vlan 10

IOU3(config-if)#ip address 192.168.10.61255.255.255.192

IOU3(config-if)#vrrp 10 ip 192.168.10.62

IOU3(config-if)#vrrp 10 priority 90

IOU3(config-if)#vrrp 10 preempt  

IOU3(config-if)#no shutdown  

IOU3(config-if)#exit

IOU3(config)#

IOU3(config)#

IOU3(config)#interface vlan 20              

IOU3(config-if)#ip address 192.168.10.124 255.255.255.192

IOU3(config-if)#vrrp 20 ip 192.168.10.126

IOU3(config-if)#vrrp 20 priority 90

IOU3(config-if)#vrrp 20 preempt  

IOU3(config-if)#no shutdown  

IOU3(config-if)#exit

IOU3(config)#

IOU3(config)#interface vlan 30

IOU3(config-if)#ip address 192.168.10.188 255.255.255.192

IOU3(config-if)#vrrp 30 ip 192.168.10.190

IOU3(config-if)#vrrp 30 priority 110

IOU3(config-if)#vrrp 30 preempt  

IOU3(config-if)#vrrp 30 track 100 decrement 30

IOU3(config-if)#no shutdown  

IOU3(config-if)#ex

IOU3(config)#

IOU3(config)#interface vlan 40                        

IOU3(config-if)#ip address 192.168.10.252 255.255.255.192

IOU3(config-if)#vrrp 40 ip 192.168.10.254  

IOU3(config-if)#vrrp 40 priority 110

IOU3(config-if)#vrrp 40 preempt  

IOU3(config-if)#vrrp 40 track 100 decrement 30

IOU3(config-if)#no shutdown  

IOU3(config-if)#exit



网络设备配置IP地址

IOU2上的配置

IOU2(config)#interface ethernet 0/0

IOU2(config-if)#no switchport  

IOU2(config-if)#ip address 172.16.1.1 255.255.255.0

IOU2(config-if)#no shutdown  


IOU3上的配置

IOU3(config)#interface ethernet 0/0

IOU3(config-if)#no switchport  

IOU3(config-if)#ip address 172.16.2.1 255.255.255.0

IOU3(config-if)#no shutdown  

IOU3(config-if)#ex


IOU1上的配置

IOU1(config)#interface ethernet 0/0

IOU1(config-if)#duplex full  

IOU1(config-if)#ip address 172.16.1.2 255.255.255.0

IOU1(config-if)#no shutdown  

IOU1(config-if)#ex

IOU1(config)#

IOU1(config)#interface ethernet 0/1

IOU1(config-if)#ip address 172.16.2.2 255.255.255.0

IOU1(config-if)#duplex full  

IOU1(config-if)#no shutdown  

IOU1(config-if)#exit

IOU1(config)#interface loopback 0

IOU1(config-if)#ip address 1.1.1.1 255.255.255.255

IOU1(config-if)#no shutdown    

IOU1(config-if)#exit



配置静态路由

IOU2上的配置

IOU2(config)#ip route 0.0.0.0 0.0.0.0 172.16.1.2

IOU3上的配置

IOU3(config)#ip route 0.0.0.0 0.0.0.0 172.16.2.2

IOU1上的配置,使用了汇总路由及浮动静态路由的配置

IOU1(config)#ip route 192.168.10.0 255.255.255.128 172.16.1.1

IOU1(config)#ip route 192.168.10.128 255.255.255.128 172.16.2.1

IOU1(config)#ip route 192.168.10.0 255.255.255.128 172.16.2.1 11

IOU1(config)#ip route 192.168.10.128 255.255.255.128 172.16.1.1 11

在IOU1上查看路由表

Cisco使用MSTP+VRRP+静态路由+子网划分+DHCP综合案例_路由表_06


配置DHCP服务

在IOU1上配置DHCP服务器

IOU1(config)#ip dhcp pool vlan10

IOU1(dhcp-config)#network 192.168.10.0 /26

IOU1(dhcp-config)#default-router 192.168.10.62

IOU1(dhcp-config)#dns-server 8.8.8.8  

IOU1(dhcp-config)#exit

IOU1(config)#ip dhcp pool vlan20         

IOU1(dhcp-config)#network 192.168.10.64 /26    

IOU1(dhcp-config)#default-router 192.168.10.126

IOU1(dhcp-config)#dns-server 8.8.8.8

IOU1(dhcp-config)#exit

IOU1(config)#ip dhcp pool vlan30  

IOU1(dhcp-config)#network 192.168.10.128 /26    

IOU1(dhcp-config)#default-router 192.168.10.190

IOU1(dhcp-config)#dns-server 8.8.8.8

IOU1(dhcp-config)#exit

IOU1(config)#ip dhcp pool vlan40        

IOU1(dhcp-config)#network 192.168.10.192 /26    

IOU1(dhcp-config)#default-router 192.168.10.254

IOU1(dhcp-config)#dns-server 8.8.8.8

IOU1(dhcp-config)#exit


在IOU2上配置DHCP中继

IOU2(config)#interface vlan 10          

IOU2(config-if)#ip helper-address 1.1.1.1

IOU2(config-if)#exit

IOU2(config)#interface vlan 20        

IOU2(config-if)#ip helper-address 1.1.1.1

IOU2(config-if)#exit

IOU2(config)#interface vlan 30       

IOU2(config-if)#ip helper-address 1.1.1.1

IOU2(config-if)#exit  

IOU2(config)#interface vlan 40      

IOU2(config-if)#ip helper-address 1.1.1.1

IOU2(config-if)#exit


在IOU3上配置DHCP中继

IOU3(config)#interface vlan 10          

IOU3(config-if)#ip helper-address 1.1.1.1

IOU3(config-if)#exit

IOU3(config)#interface vlan 20     

IOU3(config-if)#ip helper-address 1.1.1.1

IOU3(config-if)#exit

IOU3(config)#interface vlan 30        

IOU3(config-if)#ip helper-address 1.1.1.1

IOU3(config-if)#exit  

IOU3(config)#interface vlan 40        

IOU3(config-if)#ip helper-address 1.1.1.1

IOU3(config-if)#exit

在PC上验证结果

Cisco使用MSTP+VRRP+静态路由+子网划分+DHCP综合案例_静态路由_07

在PC上使用ping命令测试网络连通性

Cisco使用MSTP+VRRP+静态路由+子网划分+DHCP综合案例_服务器_08