使用MSTP+VRRP+静态路由+子网划分+DHCP综合案例_生成树

实验要求:


实验使用网段192.168.10.0/24分配IP地址,划分vlan 10~13,每个vlan不超过50台主机,配置MSTP协议实现负载均衡、配置VRRP协议实现网关备份,使用静态路由实现全网互通,在路由器上配置DHCP分发IP地址

配置干道

IOU6(config)#interface range ethernet 0/1-3

IOU6(config-if-range)#switchport trunk encapsulation dot1q 

IOU6(config-if-range)#switchport mode trunk    

IOU6(config-if-range)#exit 

以太网通道

IOU6(config)#interface range ethernet 0/0-1

IOU6(config-if-range)#channel-group 1 mode on 

IOU6(config)#interface port-channel 1

IOU6(config-if)#switchport trunk encapsulation dot1q

IOU6(config-if)#switchport mode trunk

IOU6(config-if)#exit

配置干道

IOU7(config)#interface range ethernet 0/1-3

IOU7(config-if-range)#switchport trunk encapsulation dot1q 

IOU7(config-if-range)#switchport mode trunk    

IOU7(config-if-range)#exit 

以太网通道

IOU7(config)#interface range ethernet 0/0-1

IOU7(config-if-range)#channel-group 1 mode on 

IOU7(config)#interface port-channel 1

IOU7(config-if)#switchport trunk encapsulation dot1q

IOU7(config-if)#switchport mode trunk

IOU7(config-if)#exit

封装

IOU8(config)#interface range ethernet 0/1-3

IOU8(config-if-range)#switchport trunk encapsulation dot1q  

IIOU8(config-if-range)#switchport mode trunk 

IOU8(config-if)#exit

在交换机上创建vlan

IOU6(config)#vlan 10-13

IOU6(config-vlan)#ex

IOU7(config)#vlan 10-13

IOU7(config-vlan)#ex

IOU8(config)#vlan 10-13

IOU8(config-vlan)#ex

MST多生成树

IOU6(config)#spanning-tree mode mst

IOU6(config)#spanning-tree mst configuration  

IOU6(config-mst)#name lin

IOU6(config-mst)#revision 1

IOU6(config-mst)#instance 1 vlan 10,11

IOU6(config-mst)#instance 2 vlan 12,13

IOU6(config-mst)#exit  

IOU6(config)#spanning-tree mst 1 root primary 

IOU6(config)#spanning-tree mst 2 root secondary 

IOU7(config)#spanning-tree mode mst

IOU7(config)#spanning-tree mst configuration  

IOU7(config-mst)#name lin

IOU7(config-mst)#revision 1

IOU7(config-mst)#instance 1 vlan 10,11

IOU7(config-mst)#instance 2 vlan 12,13

IOU7(config-mst)#exit  

IOU7(config)#spanning-tree mst 1 root secondary 

IOU7(config)#spanning-tree mst 2 root primary 

IOU8(config)#spanning-tree mode mst

IOU8(config)#spanning-tree mst configuration  

IOU8(config-mst)#name lin

IOU8(config-mst)#revision 1

IOU8(config-mst)#instance 1 vlan 10,11

IOU8(config-mst)#instance 2 vlan 12,13

IOU8(config-mst)#exit  

配置VRRP(端口跟踪)

IOU6(config)#track 100 interface ethernet 0/3 line-protocol

IOU6(config)#interface vlan 10

IOU6(config-if)#ip address 192.168.10.60 255.255.255.192

IOU6(config-if)#vrrp 10 ip 192.168.10.62

IOU6(config-if)#vrrp 10 priority 110

IOU6(config-if)#vrrp 10 preempt

IOU6(config-if)#vrrp 10 track 100 decrement 30

IOU6(config)#interface vlan 11

IOU6(config-if)#ip address 192.168.10.124 255.255.255.192

IOU6(config-if)#vrrp 11 ip 192.168.10.126

IOU6(config-if)#vrrp 11 priority 110

IOU6(config-if)#vrrp 11 preempt

IOU6(config-if)#vrrp 11 track 100 decrement 30

IOU6(config)#interface vlan 12

IOU6(config-if)#ip address 192.168.10.188 255.255.255.192

IOU6(config-if)#vrrp 12 ip 192.168.10.190

IOU6(config-if)#vrrp 12 priority 90

IOU6(config-if)#vrrp 12 preempt

IOU6(config)#interface vlan 13

IOU6(config-if)#ip address 192.168.10.252 255.255.255.192

IOU6(config-if)#vrrp 13 ip 192.168.10.254

IOU6(config-if)#vrrp 13 priority 90

IOU6(config-if)#vrrp 13 preempt

IOU7(config)#track 100 interface ethernet 0/3 line-protocol

IOU7(config-track)#ex

IOU7(config)#interface vlan 10

IOU7(config-if)#ip address 192.168.10.61 255.255.255.192

IOU7(config-if)#vrrp 10 ip 192.168.10.62

IOU7(config-if)#vrrp 10 priority 90

IOU7(config-if)#vrrp 10 preempt

IOU7(config-if)#no shutdown

IOU7(config-if)#interface vlan 11

IOU7(config-if)#ip address 192.168.10.125 255.255.255.192

IOU7(config-if)#vrrp 11 ip 192.168.10.126

IOU7(config-if)#vrrp 11 priority 90

IOU7(config-if)#vrrp 11 preempt

IOU7(config-if)#no shutdown

IOU7(config-if)#interface vlan 12

IOU7(config-if)#ip address 192.168.10.189 255.255.255.192

IOU7(config-if)#vrrp 12 ip 192.168.10.190

IOU7(config-if)#vrrp 12 priority 110

IOU7(config-if)#vrrp 12 preempt

IOU7(config-if)#vrrp 12 track 100 decrement 30

IOU7(config-if)#no shutdown

IOU7(config-if)#interface vlan 13

IOU7(config-if)#ip address 192.168.10.253 255.255.255.192

IOU7(config-if)#vrrp 13 ip 192.168.10.254

IOU7(config-if)#vrrp 13 priority 110

IOU7(config-if)#vrrp 13 preempt

IOU7(config-if)#vrrp 13 track 100 decrement 30

IOU7(config-if)#no shutdown

配置IP地址

IOU6(config)#interface ethernet 0/3

IOU6(config-if)#no switchport

IOU6(config-if)#ip address 172.16.1.1 255.255.255.0

IOU6(config-if)#no shutdown

IOU7(config)#interface ethernet 0/3

IOU7(config-if)#no switchport

IOU7(config-if)#ip address 172.16.2.1 255.255.255.0

IOU7(config-if)#no shutdown

IOU1(config)#interface ethernet 0/0

IOU1(config-if)#duplex full

IOU1(config-if)#ip address 172.16.1.2 255.255.255.0

IOU1(config-if)#no shutdown

IOU1(config-if)#ex

IOU1(config)#interface ethernet 0/1

IOU1(config-if)#duplex full

IOU1(config-if)#ip address 172.16.2.2 255.255.255.0

IOU1(config-if)#no shutdown

IOU1(config-if)#ex

IOU1(config)#interface loo0

IOU1(config-if)#ip address 1.1.1.1 255.255.255.255

IOU1(config-if)#ex

配置静态/默认路由

IOU6(config)#ip route 0.0.0.0 0.0.0.0 172.16.1.2

IOU7(config)#ip route 0.0.0.0 0.0.0.0 172.16.2.2

IOU1(config)#ip route 192.168.10.0 255.255.255.128 172.16.1.1

IOU1(config)#ip route 192.168.10.128 255.255.255.128 172.16.2.1

IOU1(config)#ip route 192.168.10.0 255.255.255.128 172.16.2.1 11

IOU1(config)#ip route 192.168.10.128 255.255.255.128 172.16.1.1 11

配置DHCP

IOU1(config)#ip dhcp pool vlan10

IOU1(dhcp-config)#network 192.168.10.0 /26

IOU1(dhcp-config)#default-router 192.168.10.62

IOU1(dhcp-config)#dns-server 8.8.8.8

IOU1(dhcp-config)#exit

IOU1(config)#ip dhcp pool vlan11

IOU1(dhcp-config)#network 192.168.10.64 /26

IOU1(dhcp-config)#default-router 192.168.10.126

IOU1(dhcp-config)#dns-server 8.8.8.8

IOU1(dhcp-config)#exit

IOU1(config)#ip dhcp pool vlan12

IOU1(dhcp-config)#network 192.168.10.128 /26

IOU1(dhcp-config)#default-router 192.168.10.190

IOU1(dhcp-config)#dns-server 8.8.8.8

IOU1(dhcp-config)#exit

IOU1(config)#ip dhcp pool vlan13

IOU1(dhcp-config)#network 192.168.10.192 /26

IOU1(dhcp-config)#default-router 192.168.10.254

IOU1(dhcp-config)#dns-server 8.8.8.8

IOU1(dhcp-config)#exit

IOU6(config)#interface vlan 10

IOU6(config-if)#ip helper-address 1.1.1.1

IOU6(config-if)#interface vlan 11

IOU6(config-if)#ip helper-address 1.1.1.1

IOU6(config-if)#interface vlan 12

IOU6(config-if)#ip helper-address 1.1.1.1

IOU6(config)#interface vlan 13

IOU6(config-if)#ip helper-address 1.1.1.1

IOU6(config-if)#ex

IOU7(config)#interface vlan 10

IOU7(config-if)#ip helper-address 1.1.1.1

IOU7(config-if)#interface vlan 11

IOU7(config-if)#ip helper-address 1.1.1.1

IOU7(config-if)#interface vlan 12

IOU7(config-if)#ip helper-address 1.1.1.1

IOU7(config)#interface vlan 13

IOU7(config-if)#ip helper-address 1.1.1.1