使用mstp+vrrp+静态路由+子网划分+DHCP实验案例_ip地址

在此拓扑上规划的ip地址

IOU1

e0/0:172.16.1.2/24


e0/0:172.16.2.2/24


loo0:1.1.1.1/32


IOU2

vlan13:192.168.10.252/26

vip:192.168.10.254

vlan10:192.168.10.60/26

vip:192.168.10.62/26

vlan11:192.168.10.124/26

vip:192.168.10.126/26

vlan12:192.168.10.188/26

vip:192.168.10.190

IOU3



vlan10:192.168.10.61/26

vip:192.168.10.62/26

vlan11:192.168.10.125/26

vip:192.168.10.126/26

vlan12:192.168.10.189/26

vip:192.168.10.190

vlan:13192.168.10.253/26

vip:192.168.10.254

创建vlan

IOU2

IOU2(config)#vlan 10-13

IOU2(config-vlan)#exit

 使用mstp+vrrp+静态路由+子网划分+DHCP实验案例_ip地址_02

 

IOU3

IOU3(config)#vlan 10-13

IOU3(config-vlan)#exit

 使用mstp+vrrp+静态路由+子网划分+DHCP实验案例_ip地址_03

 

IOU4

IOU4(config)#vlan 10-13

IOU4(config-vlan)#exit

 使用mstp+vrrp+静态路由+子网划分+DHCP实验案例_ip地址_04

 

二层交换机接口配置trunk

IOU2

IOU2(config)#interface range ethernet 0/0-2

IOU2(config-if-range)#switchport trunk encapsulation dot1q 

IOU2(config-if-range)#switchport mode trunk

IOU2(config-if-range)#exit

 

IOU3

IOU3(config)#interface range ethernet 0/0-2

IOU3(config-if-range)#switchport trunk encapsulation dot1q

IOU3(config-if-range)#switchport mode trunk

IOU3(config-if-range)#exit

 

IOU4

IOU4(config)#interface range ethernet 0/0-1

IOU4(config-if-range)#switchport trunk encapsulation dot1q

IOU4(config-if-range)#switchport mode trunk

IOU4(config-if-range)#exit

 

配置以太网通道

IOU2

IOU2(config)#interface range ethernet 0/0-1

IOU2(config-if-range)#channel-group 1 mode on

Creating a port-channel interface Port-channel 1

IOU2(config-if-range)#exit

 

IOU3

IOU3(config)#interface range ethernet 0/0-1

IOU3(config-if-range)#channel-group 1 mode on

Creating a port-channel interface Port-channel 1

IOU3(config-if-range)#exit

 

配置多生成树

IOU2

IOU2(config)#spanning-tree mode mst

IOU2(config)#spanning-tree mst configuration

IOU2(config-mst)#name cisco

IOU2(config-mst)#revision 1

IOU2(config-mst)#instance 1 vlan 10,11

IOU2(config-mst)#instance 2 vlan 12,13

IOU2(config-mst)#exit

IOU2(config)#spanning-tree mst 1 root primary 

IOU2(config)#spanning-tree mst 2 root secondary 

 

 

IOU3

IOU3(config)#spanning-tree mode mst

IOU3(config)#spanning-tree mst configuration

IOU3(config-mst)#name cisco

IOU3(config-mst)#revision 1

IOU3(config-mst)#instance 1 vlan 10,11

IOU3(config-mst)#instance 2 vlan 12,13

IOU3(config-mst)#exit

IOU3(config)#spanning-tree mst 1 root secondary

IOU3(config)#spanning-tree mst 2 root primary

 

IOU4

IOU4(config)#spanning-tree mode mst

IOU4(config)#spanning-tree mst configuration

IOU4(config-mst)#name cisco

IOU4(config-mst)#revision 1

IOU4(config-mst)#instance 1 vlan 10,11

IOU4(config-mst)#instance 2 vlan 12,13

IOU4(config-mst)#exit

 使用mstp+vrrp+静态路由+子网划分+DHCP实验案例_静态路由_05

使用mstp+vrrp+静态路由+子网划分+DHCP实验案例_外网_06 

 

 

配置SVI,vlan的物理ip地址

IOU2

IOU2(config)#int vlan 10

IOU2(config-if)#ip address 192.168.10.60 255.255.255.192

IOU2(config-if)#no shutdown

IOU2(config-if)#exit

 

IOU2(config)#int vlan 11

IOU2(config-if)#ip address 192.168.10.124 255.255.255.192

IOU2(config-if)#no shutdown

IOU2(config-if)#exit

 

IOU2(config)#int vlan 12

IOU2(config-if)#ip address 192.168.10.188 255.255.255.192

IOU2(config-if)#no shutdown

IOU2(config-if)#exit

 

IOU2(config)#interface vlan 13

IOU2(config-if)#ip address 192.168.10.252 255.255.255.192

IOU2(config-if)#no shutdown

IOU2(config-if)#exit

 

IOU3

IOU3(config)#int vlan 10

IOU3(config-if)#ip address 192.168.10.61 255.255.255.192

IOU3(config-if)#no shutdown

IOU3(config-if)#exit

 

IOU3(config)#interface vlan 11

IOU3(config-if)#ip address 192.168.10.125 255.255.255.192

IOU3(config-if)#no shutdown

IOU3(config-if)#exit

 

IOU3(config)#interface vlan 12

IOU3(config-if)#ip address 192.168.10.189 255.255.255.192

IOU3(config-if)#no shutdown

IOU3(config-if)#exit

 

IOU3(config)#interface vlan 13

IOU3(config-if)#ip address 192.168.10.253 255.255.255.192

IOU3(config-if)#no shutdown

IOU3(config-if)#exit

 

配置vrrp

IOU2

IOU2(config)#interface vlan 10

IOU2(config-if)#vrrp 10 ip 192.168.10.62

IOU2(config-if)#vrrp 10 priority 110

IOU2(config-if)#vrrp 10 preempt

IOU2(config-if)#exit

 

IOU2(config)#interface vlan 11

IOU2(config-if)#vrrp 11 ip 192.168.10.126

IOU2(config-if)#vrrp 11 priority 110

IOU2(config-if)#vrrp 11 preempt

IOU2(config-if)#exit

 

IOU2(config)#interface vlan 12

IOU2(config-if)#vrrp 12 ip 192.168.10.190

IOU2(config-if)#vrrp 12 priority 90

IOU2(config-if)#vrrp 12 preempt

IOU2(config-if)#exit

 

IOU2(config)#interface vlan 13

IOU2(config-if)#vrrp 13 ip 192.168.10.254

IOU2(config-if)#vrrp 13 priority 90

IOU2(config-if)#vrrp 13 preempt

IOU2(config-if)#exit

 

IOU3

IOU3(config)#interface vlan 10

IOU3(config-if)#vrrp 10 ip 192.168.10.62

IOU3(config-if)#vrrp 10 priority 90

IOU3(config-if)#vrrp 10 preempt

IOU3(config-if)#exit

 

IOU3(config)#interface vlan 11

IOU3(config-if)#vrrp 11 ip 192.168.10.126

IOU3(config-if)#vrrp 11 priority 90

IOU3(config-if)#vrrp 11 preempt

IOU3(config-if)#exit

 

IOU3(config)#interface vlan 12

IOU3(config-if)#vrrp 12 ip 192.168.10.190

IOU3(config-if)#vrrp 12 priority 110

IOU3(config-if)#vrrp 12 preempt

IOU3(config-if)#exit

 

IOU3(config)#interface vlan 13

IOU3(config-if)#vrrp 13 ip 192.168.10.254

IOU3(config-if)#vrrp 13 priority 110

IOU3(config-if)#vrrp 13 preempt

IOU3(config-if)#exit

 

在IOU2将连接三层设备的二层接口升级成三层接口

IOU2(config)#interface ethernet 0/3

IOU2(config-if)#no switchport

IOU2(config-if)#ip address 172.16.1.1 255.255.255.0

IOU2(config-if)#no shutdown

IOU2(config-if)#exit

 

在IOU3将连接三层设备的二层接口升级成三层接口

IOU3(config)#interface ethernet 0/3

IOU3(config-if)#no switchport

IOU3(config-if)#ip address 172.16.2.1 255.255.255.0

IOU3(config-if)#no shutdown

IOU3(config-if)#exit

 

在IOU2、IOU3上的ethernet0/3接口上配置端口跟踪

IOU2

IOU2(config)#track 100 interface ethernet 0/3 line-protocol

IOU2(config-track)#exit

IOU2(config)#interface vlan 10

IOU2(config-if)#vrrp 10 track 100 decrement 30

IOU2(config-if)#exit

IOU2(config)#interface vlan 11

IOU2(config-if)#vrrp 11 track 100 decrement 30

IOU2(config-if)#exit

当IOU2交换机的接口et0/2接口断掉后,IUO3将快速承担起转发vlan10,vlan11数据

 使用mstp+vrrp+静态路由+子网划分+DHCP实验案例_ip地址_07

 使用mstp+vrrp+静态路由+子网划分+DHCP实验案例_外网_08

当IOU2的et0/3恢复后又会被抢占回去

 使用mstp+vrrp+静态路由+子网划分+DHCP实验案例_静态路由_09

IOU3

IOU3(config)#track 100 interface ethernet 0/3 line-protocol

IOU3(config-track)#exit

IOU3(config)#interface vlan 12

IOU3(config-if)#vrrp 12 track 100 decrement 30

IOU3(config-if)#exit

IOU3(config)#interface vlan 13

IOU3(config-if)#vrrp 13 track 100 decrement 30

IOU3(config-if)#exit

 

在IOU1路由器上配置

IOU1(config)#interface ethernet 0/0

IOU1(config-if)#duplex full

IOU1(config-if)#no shutdown

IOU1(config-if)#ip address 172.16.1.2 255.255.255.0

IOU1(config-if)#exit

 

IOU1(config)#interface ethernet 0/1

IOU1(config-if)#duplex full

IOU1(config-if)#no shutdown

IOU1(config-if)#ip address 172.16.2.2 255.255.255.0

IOU1(config-if)#exit

 

IOU1(config)#interface loopback 0

IOU1(config-if)#ip address 1.1.1.1 255.255.255.255

IOU1(config-if)#exit

 

在IOU1路由器上配置DHCP

IOU1(config)#ip dhcp pool vlan10

IOU1(dhcp-config)#network 192.168.10.0 /26

IOU1(dhcp-config)#default-router 192.168.10.62

IOU1(dhcp-config)#dns-server 8.8.8.8

IOU1(dhcp-config)#exit

 

IOU1(config)#ip dhcp pool vlan11

IOU1(dhcp-config)#network 192.168.10.64 /26

IOU1(dhcp-config)#default-router 192.168.10.126

IOU1(dhcp-config)#dns-server 8.8.8.8

IOU1(dhcp-config)#exit

 

IOU1(config)#ip dhcp pool vlan12

IOU1(dhcp-config)#network 192.168.10.128 /26

IOU1(dhcp-config)#default-router 192.168.10.190

IOU1(dhcp-config)#dns-server 8.8.8.8

IOU1(dhcp-config)#exit

 

IOU1(config)#ip dhcp pool vlan13

IOU1(dhcp-config)#network 192.168.10.192 /26

IOU1(dhcp-config)#default-router 192.168.10.254

IOU1(dhcp-config)#dns-server 8.8.8.8

IOU1(dhcp-config)#exit

 

在IOU路由器上配置静态路由

IOU1(config)#ip route 192.168.10.0 255.255.255.128 172.16.1.1

IOU1(config)#ip route 192.168.10.0 255.255.255.128 172.16.2.1 11

IOU1(config)#ip route 192.168.10.128 255.255.255.128 172.16.1.1 11

IOU1(config)#ip route 192.168.10.128 255.255.255.128 172.16.2.1

使用mstp+vrrp+静态路由+子网划分+DHCP实验案例_静态路由_10 

 

 使用mstp+vrrp+静态路由+子网划分+DHCP实验案例_ip地址_11

 

在IOU2上配置DHCP中继

IOU2(config)#interface vlan 10

IOU2(config-if)#ip helper-address 1.1.1.1

IOU2(config-if)#exit

IOU2(config)#interface vlan 11

IOU2(config-if)#ip helper-address 1.1.1.1

IOU2(config-if)#exit

IOU2(config)#interface vlan 12

IOU2(config-if)#ip helper-address 1.1.1.1

IOU2(config-if)#exit

IOU2(config)#interface vlan 13

IOU2(config-if)#ip helper-address 1.1.1.1

IOU2(config-if)#exit

 

配置去往外网的默认路由

IOU2(config)#ip route 0.0.0.0 0.0.0.0 172.16.1.2

 

在IOU3上配置DHCP中继

IOU3(config)#interface vlan 10

IOU3(config-if)#ip helper-address 1.1.1.1

IOU3(config-if)#exit

IOU3(config)#interface vlan 11

IOU3(config-if)#ip helper-address 1.1.1.1

IOU3(config-if)#exit

IOU3(config)#interface vlan 12

IOU3(config-if)#ip helper-address 1.1.1.1

IOU3(config-if)#exit

IOU3(config)#interface vlan 13

IOU3(config-if)#ip helper-address 1.1.1.1

IOU3(config-if)#exit

 

配置去往外网的默认路由

IOU3(config)#ip route 0.0.0.0 0.0.0.0 172.16.2.2

 

将IOU4上的接口e0/2、e0/3、e1/0、e1/1加入到vlan

IOU4(config)#interface ethernet 0/2

IOU4(config-if)#switchport mode access

IOU4(config-if)#switchport access vlan 10

IOU4(config-if)#exit

IOU4(config)#interface ethernet 0/3

IOU4(config-if)#switchport mode access   

IOU4(config-if)#switchport access vlan 11

IOU4(config-if)#exit     

IOU4(config)#interface ethernet 1/0

IOU4(config-if)#switchport mode access

IOU4(config-if)#switchport access vlan 12

IOU4(config-if)#exit

IOU4(config)#interface ethernet 1/1

IOU4(config-if)#switchport mode access

IOU4(config-if)#switchport access vlan 13

IOU4(config-if)#exit

 

在IOU5上配置

IOU5(config)#int ethernet 0/0

IOU5(config-if)#duplex full

IOU5(config-if)#no shutdown

IOU5(config-if)#ip address dhcp

IOU5(config-if)#exit

使用mstp+vrrp+静态路由+子网划分+DHCP实验案例_静态路由_12 

 

在IOU6上配置

IOU6(config)#int ethernet 0/0

IOU6(config-if)#duplex full

IOU6(config-if)#no shutdown

IOU6(config-if)#ip address dhcp

IOU6(config-if)#exit

 使用mstp+vrrp+静态路由+子网划分+DHCP实验案例_静态路由_13

 

在IOU7上配置

IOU7(config)#int ethernet 0/0

IOU7(config-if)#duplex full

IOU7(config-if)#no shutdown

IOU7(config-if)#ip address dhcp

IOU7(config-if)#exit

 使用mstp+vrrp+静态路由+子网划分+DHCP实验案例_ip地址_14

 

在IOU8上配置

IOU8(config)#int ethernet 0/0

IOU8(config-if)#duplex full

IOU8(config-if)#no shutdown

IOU8(config-if)#ip address dhcp

IOU8(config-if)#exit

 使用mstp+vrrp+静态路由+子网划分+DHCP实验案例_ip地址_15

 

 

使用ping命令测试网络

 使用mstp+vrrp+静态路由+子网划分+DHCP实验案例_ip地址_16