实验需求

实验使用网段192.168.10.0/24分配IP地址,划分vlan 10~13,每个vlan不超过50台主机,配置MSTP协议实现负载均衡、配置VRRP协议实现网关备份,使用静态路由实现全网互通,在路由器上配置DHCP分发IP地址


实验拓扑如下:

Cisco MSTP+VRRP+DHCP+静态路由综合实验_生成树

在此拓扑上规划的IP地址如下:

Cisco MSTP+VRRP+DHCP+静态路由综合实验_三层交换机_02

第一步在三层交换机上配置封装模式,步骤如下:

四台主机分别匹配vlan 10、11、12、13

IOU1上的配置:

IOU1(config)#vlan 10-13 
IOU1(config)#exit
IOU1(config)#interface range ethernet 0/0-1
IOU1(config-if-range)#channel-group 1 mode on
IOU1(config)#interface range ethernet 0/0-2
IOU1(config-if-range)#switchport trunk encapsulation dot1q
IOU1(config-if-range)#switchport mode trunk
IOU1(config-if-range)#exit

IOU2的配置与IOU1基本相同:

IOU2(config)#vlan 10-13 
IOU2(config-vlan)#exit
IOU2(config)#interface range ethernet 0/0-1
IOU2(config-if-range)#channel-group 1 mode on
IOU2(config-if-range)#exit
IOU2(config)#interface range ethernet 0/0-2
IOU2(config-if-range)#switchport trunk encapsulation dot1q
IOU2(config-if-range)#switchport mode trunk
IOU2(config-if-range)#ex

IOU3上配置封装模式:

//二层交换机只需要配置与三层交换机相连的接口为trunk模式

IOU3(config)#vlan 10-13
IOU3(config-vlan)#exit
IOU3(config)#interface range ethernet 0/0-1
IOU3(config-if-range)#switchport trunk encapsulation dot1q
IOU3(config-if-range)#switchport mode trunk
IOU3(config-if-range)#exit

第二步:配置多生成树以及配置vlan的主根与备根:

IOU1上配置为多生成树:

IOU1(config)#spanning-tree mode mst  
IOU1(config)#spanning-tree mst configuration
IOU1(config-mst)#name chengjie
IOU1(config-mst)#revision 1
IOU1(config-mst)#instance 1 vlan 10,11
IOU1(config-mst)#instance 2 vlan 12,13
IOU1(config)#spanning-tree mst 1 root primary
IOU1(config)#spanning-tree mst 2 root secondary

IOU2配置为多生成树:

IOU2(config)#spanning-tree mode mst
IOU2(config)#spanning-tree mst configuration
IOU2(config-mst)#name chengjie
IOU2(config-mst)#revision 1
IOU2(config-mst)#instance 1 vlan 10,11
IOU2(config-mst)#instance 2 vlan 12,13
IOU2(config-mst)#exit
IOU2(config)#spanning-tree mst 1 root secondary
IOU2(config)#spanning-tree mst 2 root primary

IOU3的配置

IOU3(config)#spanning-tree mode mst
IOU3(config)#spanning-tree mst configuration
IOU3(config-mst)#name chengjie
IOU3(config-mst)#revision 1
IOU3(config-mst)#instance 1 vlan 10,11
IOU3(config-mst)#instance 2 vlan 12,13
IOU3(config-mst)#exit

第三步:分别配置vlan10-13的SVI接口并设置端口跟踪:

IOU1(config)#interface vlan 10 //创建vlan10 的SVI接口
IOU1(config-if)#ip address 192.168.10.60 255.255.255.192
IOU1(config-if)#vrrp 10 ip 192.168.10.62
IOU1(config-if)#vrrp 10 priority 110
IOU1(config-if)#vrrp 10 preempt
IOU1(config-if)#no shutdown
IOU1(config-if)#ex
IOU1(config)#interface vlan 11
IOU1(config-if)#ip address 192.168.10.124 255.255.255.192
IOU1(config-if)#vrrp 11 ip 192.168.10.126
IOU1(config-if)#vrrp 11 priority 110
IOU1(config-if)#vrrp 11 preempt
IOU1(config-if)#no shutdown
IOU1(config-if)#ex
IOU1(config)#interface vlan 12
IOU1(config-if)#ip address 192.168.10.188 255.255.255.192
IOU1(config-if)#vrrp 12 ip 192.168.10.190
IOU1(config-if)#vrrp 12 priority 90
IOU1(config-if)#vrrp 12 preempt
IOU1(config-if)#no shutdown
IOU1(config-if)#exit
IOU1(config)#interface vlan 13
IOU1(config-if)#ip address 192.168.10.252 255.255.255.192
IOU1(config-if)#vrrp 13 ip 192.168.10.254
IOU1(config-if)#vrrp 13 priority 90
IOU1(config-if)#vrrp 13 preempt
IOU1(config-if)#no shutdown
IOU1(config-if)#exit

配置完成vrrp并查看结果如下:

Cisco MSTP+VRRP+DHCP+静态路由综合实验_ip地址_03

IOU1(config)#track 100 interface ethernet 0/3 line-protocol  
IOU1(config-track)#ex
IOU1需要跟踪的vlan为10,11
IOU1(config)#interface vlan 10
IOU1(config-if)#vrrp 10 track 100 decrement 30
IOU1(config-if)#exit
IOU1(config)#interface vlan 11
IOU1(config-if)#vrrp 11 track 100 decrement 30
IOU1(config-if)#exit

IOU2的配置

IOU2(config)#interface vlan 10
IOU2(config-if)#ip address 192.168.10.61 255.255.255.192
IOU2(config-if)#vrrp 10 ip 192.168.10.62
IOU2(config-if)#vrrp 10 priority 90
IOU2(config-if)#vrrp 10 preempt
IOU2(config-if)#no shutdown
IOU2(config-if)#ex
IOU2(config)#interface vlan 11
IOU2(config-if)#ip address 192.168.10.125 255.255.255.192
IOU2(config-if)#vrrp 11 ip 192.168.10.126
IOU2(config-if)#vrrp 11 priority 90
IOU2(config-if)#vrrp 11 preempt
IOU2(config-if)#no shutdown
IOU2(config-if)#exit
IOU2(config)#interface vlan 12
IOU2(config-if)#ip address 192.168.10.189 255.255.255.192
IOU2(config-if)#vrrp 12 ip 192.168.10.190
IOU2(config-if)#vrrp 12 priority 110
IOU2(config-if)#vrrp 12 preempt
IOU2(config-if)#no shutdown
IOU2(config-if)#exit
IOU2(config)#interface vlan 13
IOU2(config-if)#ip address 192.168.10.253 255.255.255.192
IOU2(config-if)#vrrp 13 ip 192.168.10.254
IOU2(config-if)#vrrp 13 priority 110
IOU2(config-if)#vrrp 13 preempt
IOU2(config-if)#no shutdown
IOU2(config-if)#exit

IOU2配置完VRRP后查看结果如下:

Cisco MSTP+VRRP+DHCP+静态路由综合实验_三层交换机_04

IOU2(config)#track 100 interface ethernet 0/3 line-protocol  
IOU2(config-track)#exit
IOU2(config)#interface vlan 12
IOU2(config-if)#vrrp 12 track 100 decrement 30
IOU2(config-if)#exit
IOU2(config)#interface vlan 13
IOU2(config-if)#vrrp 13 track 100 decrement 30
IOU2(config-if)#exit

第四步:在路由器上配置静态路由和DHCP:

IOU4(config)#interface ethernet 0/0
IOU4(config-if)#duplex full
IOU4(config-if)#ip address 172.16.1.2 255.255.255.0
IOU4(config-if)#no shutdown
IOU4(config-if)#exit
IOU4(config)#interface ethernet 0/1
IOU4(config-if)#duplex full
IOU4(config-if)#ip address 172.16.2.2 255.255.255.0
IOU4(config-if)#no shutdown
IOU4(config-if)#exit
IOU4(config)#interface loopback 0
IOU4(config-if)#ip address 1.1.1.1 255.255.255.255
IOU4(config-if)#no shutdown
IOU4(config-if)#exit
IOU4(config)#ip dhcp pool vlan10
IOU4(dhcp-config)#network 192.168.10.0 /26
IOU4(dhcp-config)#default-router 192.168.10.62
IOU4(dhcp-config)#dns-server 8.8.8.8
IOU4(dhcp-config)#exit
IOU4(config)#ip dhcp pool vlan11
IOU4(dhcp-config)#network 192.168.10.64 /26
IOU4(dhcp-config)#default-router 192.168.10.126
IOU4(dhcp-config)#dns-server 8.8.8.8
IOU4(dhcp-config)#exit
IOU4(config)#ip dhcp pool vlan12
IOU4(dhcp-config)#network 192.168.10.128 /26
IOU4(dhcp-config)#default-router 192.168.10.190
IOU4(dhcp-config)#dns-server 8.8.8.8
IOU4(dhcp-config)#exit
IOU4(config)#ip dhcp pool vlan13
IOU4(dhcp-config)#network 192.168.10.192 /26
IOU4(dhcp-config)#default-router 192.168.10.254
IOU4(dhcp-config)#dns-server 8.8.8.8
IOU4(dhcp-config)#exit
IOU4(config)#ip route 192.168.10.0 255.255.255.128 172.16.1.1
IOU4(config)#ip route 192.168.10.128 255.255.255.128 172.16.2.1
IOU4(config)#ip route 192.168.10.0 255.255.255.128 172.16.2.1 11
IOU4(config)#ip route 192.168.10.128 255.255.255.128 172.16.1.1 11

第五步:在三层交换机上配置DHCP中继和默认路由:

IOU1的配置

IOU1(config)#interface vlan 10
IOU1(config-if)#ip helper-address 1.1.1.1
IOU1(config-if)#exit
IOU1(config)#interface vlan 11
IOU1(config-if)#ip helper-address 1.1.1.1
IOU1(config-if)#exit
IOU1(config)#ip route 0.0.0.0 0.0.0.0 172.16.1.2

IOU2的配置

IOU2(config)#interface vlan 12
IOU2(config-if)#ip helper-address 1.1.1.1
IOU2(config-if)#exit
IOU2(config)#interface vlan 13
IOU2(config-if)#ip helper-address 1.1.1.1
IOU2(config-if)#exit
IOU2(config)#ip route 0.0.0.0 0.0.0.0 172.16.2.2

第六步:在二层交换机上将端口分别加入vlan:

IOU3(config)#interface ethernet 0/2
IOU3(config-if)#switchport mode access
IOU3(config-if)#switchport access vlan 10
IOU3(config-if)#exit
IOU3(config)#interface ethernet 0/3
IOU3(config-if)#switchport mode access
IOU3(config-if)#switchport access vlan 11
IOU3(config-if)#exit
IOU3(config)#interface ethernet 1/0
IOU3(config-if)#switchport mode access
IOU3(config-if)#switchport access vlan 12
IOU3(config-if)#exit
IOU3(config)#interface ethernet 1/1
IOU3(config-if)#switchport mode access
IOU3(config-if)#switchport access vlan 13
IOU3(config-if)#exit

在主机IOU5上配置DHCP获取IP:

IOU5(config)#interface ethernet 0/0
IOU5(config-if)#du full
IOU5(config-if)#ip add dhcp
IOU5(config-if)#no shutdown
IOU5(config-if)#exit

配置完成在主机上ping通测试:Cisco MSTP+VRRP+DHCP+静态路由综合实验_三层交换机_05