实验需求

1、掌握子网划分

2、掌握MSTP协议配置及使用场景

3、掌握VRRP协议配置及使用场景

4、掌握DHCP服务器及中继配置

5、掌握静态路由器的配置及使用场景

实验拓扑


MSTP+VRRP+静态路由+子网划分+DHCP综合案例_ip地址

IP地址规划

MSTP+VRRP+静态路由+子网划分+DHCP综合案例_热备份_02

配置步骤

1、交换机之间配置Trunk

#配置IOU4trunk
IOU4(config)#int range e1/0-1
IOU4(config-if-range)#sw tr en d
IOU4(config-if-range)#sw m tr
IOU4(config-if-range)#exit
#配置IOU1聚合链路及trunk
IOU1(config)#int range e0/1-2
IOU1(config-if-range)#channel-group 1 mode on
Creating a port-channel interface Port-channel 1
IOU1(config-if-range)#sw tr en d
IOU1(config-if-range)#sw m tr
IOU1(config-if-range)#exit
IOU1(config)#int e0/0
IOU1(config)#sw tr en d
IOU1(config)#sw m tr
#配置IOU3聚合链路及trunk
IOU3(config)#int range e0/1-2
IOU3(config-if-range)#channel-group 1 mode on
Creating a port-channel interface Port-channel 1
IOU3(config-if-range)#sw tr en d
IOU3(config-if-range)#sw m tr
IOU3(config-if-range)#exit
IOU3(config)#int e0/0
IOU3(config)#sw tr en d
IOU3(config)#sw m tr

使用do show interface trunk命令查看配置结果,可以看到Et0/0和Po1均成功配置为trunk

MSTP+VRRP+静态路由+子网划分+DHCP综合案例_热备份_03

2、创建vlan

#IOU4上创建vlan
IOU4(config)#vlan 10-13
#IOU1上创建vlan
IOU1(config)#vlan 10-13
#IOU3上创建vlan
IOU3(config)#vlan 10-13

使用do sh vlan查看创建情况

MSTP+VRRP+静态路由+子网划分+DHCP综合案例_ip地址_04

3、配置MSTP多生成树协议

#IOU1上配置mst及根桥实现负载均衡
IOU1(config)#spanning-tree mode mst
IOU1(config)#spanning-tree mst configuration
IOU1(config-mst)#name cisco
IOU1(config-mst)#revision 1
IOU1(config-mst)#instance 1 vlan 10-11
IOU1(config-mst)#instance 2 vlan 12-13
IOU1(config-mst)exit
IOU1(config)#spanning-tree mst 1 root primary
IOU1(config)#spanning-tree mst 2 root secondary
#IOU3上配置mst及根桥实现负载均衡
IOU1(config)#spanning-tree mode mst
IOU1(config)#spanning-tree mst configuration
IOU1(config-mst)#name cisco
IOU1(config-mst)#revision 1
IOU1(config-mst)#instance 1 vlan 10-11
IOU1(config-mst)#instance 2 vlan 12-13
IOU1(config-mst)exit
IOU1(config)#spanning-tree mst 1 root secondary
IOU1(config)#spanning-tree mst 2 root primary

通过do sh spanning-tree mst命令查看mst

MSTP+VRRP+静态路由+子网划分+DHCP综合案例_ip地址_05

MSTP+VRRP+静态路由+子网划分+DHCP综合案例_热备份_06


4、配置VRRP

#IOU1上配置vlan 10热备份
IOU1(config)#track 100 int e0/3 l
IOU1(config-track)#int vlan 10
IOU1(config-track)#ip add 192.168.10.60 255.255.255.192
IOU1(config-if)#vrrp 10 ip 192.168.10.62
IOU1(config-if)#vrrp 10 priority 110
IOU1(config-if)#vrrp 10 preempt
IOU1(config-if)#vrrp 10 track 100 d 30
IOU1(config-if)#no sh
#IOU1上配置vlan 11热备份
IOU1(config-track)#int vlan 11
IOU1(config-track)#ip add 192.168.10.124 255.255.255.192
IOU1(config-if)#vrrp 11 ip 192.168.10.126
IOU1(config-if)#vrrp 11 priority 110
IOU1(config-if)#vrrp 11 preempt
IOU1(config-if)#vrrp 11 track 100 d 30
IOU1(config-if)#no sh
#IOU1上配置vlan 12热备份
IOU1(config-track)#int vlan 12
IOU1(config-track)#ip add 192.168.10.188 255.255.255.192
IOU1(config-if)#vrrp 11 ip 192.168.10.190
IOU1(config-if)#vrrp 12 priority 90
IOU1(config-if)#vrrp 12 preempt
IOU1(config-if)#no sh
#IOU1上配置vlan 13热备份
IOU1(config-track)#int vlan 13
IOU1(config-track)#ip add 192.168.10.252 255.255.255.192
IOU1(config-if)#vrrp 11 ip 192.168.10.254
IOU1(config-if)#vrrp 13 priority 90
IOU1(config-if)#vrrp 13 preempt
IOU1(config-if)#no sh

使用do sh run查看配置信息

MSTP+VRRP+静态路由+子网划分+DHCP综合案例_热备份_07

#IOU3上配置vlan 10热备份
IOU3(config)#track 100 int e0/3 l
IOU3(config-track)#int vlan 10
IOU3(config-track)#ip add 192.168.10.61 255.255.255.192
IOU3(config-if)#vrrp 10 ip 192.168.10.62
IOU3(config-if)#vrrp 10 priority 90
IOU3(config-if)#vrrp 10 preempt
IOU3(config-if)#no sh
#IOU3上配置vlan 11热备份
IOU3(config-track)#int vlan 11
IOU3(config-track)#ip add 192.168.10.125 255.255.255.192
IOU3(config-if)#vrrp 11 ip 192.168.10.126
IOU3(config-if)#vrrp 11 priority 90
IOU3(config-if)#vrrp 11 preempt
IOU3(config-if)#no sh
#IOU3上配置vlan 12热备份
IOU3(config-track)#int vlan 12
IOU3(config-track)#ip add 192.168.10.189 255.255.255.192
IOU3(config-if)#vrrp 11 ip 192.168.10.190
IOU3(config-if)#vrrp 12 priority 110
IOU3(config-if)#vrrp 12 preempt
IOU3(config-if)#vrrp 12 track 100 d 30
IOU3(config-if)#no sh
#IOU3上配置vlan 13热备份
IOU3(config-track)#int vlan 13
IOU3(config-track)#ip add 192.168.10.253 255.255.255.192
IOU3(config-if)#vrrp 11 ip 192.168.10.254
IOU3(config-if)#vrrp 13 priority 110
IOU3(config-if)#vrrp 13 preempt
IOU3(config-if)#vrrp 13 track 100 d 30
IOU3(config-if)#no sh

使用do sh run查看配置信息

MSTP+VRRP+静态路由+子网划分+DHCP综合案例_ip地址_08

使用do sh vrrp b查看状态

MSTP+VRRP+静态路由+子网划分+DHCP综合案例_ip地址_09

MSTP+VRRP+静态路由+子网划分+DHCP综合案例_热备份_10

5.配置ip

#IOU1配置e0/3ip地址
IOU1(config)#int e0/3
IOU1(config-if)#no sw
IOU1(config-if)#ip add 172.168.1.1 255.255.255.0
IOU1(config-if)#no sh
#IOU3配置e0/3ip地址
IOU1(config)#int e0/3
IOU1(config-if)#no sw
IOU1(config-if)#ip add 172.168.2.1 255.255.255.0
IOU1(config-if)#no sh
#IOU2配置ip地址
IOU1(config)#int e0/0
IOU1(config-if)#duplex full
IOU1(config-if)#no sh
IOU1(config-if)#ip add 172.168.1.2 255.255.255.0
IOU1(config)#int e0/1
IOU1(config-if)#duplex full
IOU1(config-if)#no sh
IOU1(config-if)#ip add 172.168.2.2 255.255.255.0
IOU1(config)#int loopback 0
IOU1(config-if)#ip add 1.1.1.1 255.255.255.255
IOU1(config-if)#no sh

6、配置静态路由

IOU1上的配置

IOU1(config)#ip route 0.0.0.0 0.0.0.0 172.168.1.2

IOU3上的配置

IOU3(config)#ip route 0.0.0.0 0.0.0.0 172.168.2.2

IOU2上的配置

IOU2(config)#ip route 192.168.10.0 255.255.255.128 172.16.1.1
IOU2(config)#ip route 192.168.10.128 255.255.255.128 172.16.2.1
IOU2(config)#ip route 192.168.10.128 255.255.255.128 172.16.1.1 11
IOU2(config)#ip route 192.168.10.0 255.255.255.128 172.16.2.1 11

查看IOU2的路由表

MSTP+VRRP+静态路由+子网划分+DHCP综合案例_热备份_11

7、配置DHCP

IOU2(config)#ip dhcp pool v10
IOU2(dhcp-config)#network 192.168.10.0 /26
IOU2(dhcp-config)#default-router 192.168.10.62
IOU2(dhcp-config)#dns-server 8.8.8.8
IOU2(dhcp-config)#exit
IOU2(config)#ip dhcp pool v10
IOU2(dhcp-config)#network 192.168.10.64 /26
IOU2(dhcp-config)#default-router 192.168.10.126
IOU2(dhcp-config)#dns-server 8.8.8.8
IOU2(dhcp-config)#exit
IOU2(config)#ip dhcp pool v10
IOU2(dhcp-config)#network 192.168.10.128 /26
IOU2(dhcp-config)#default-router 192.168.10.190
IOU2(dhcp-config)#dns-server 8.8.8.8
IOU2(dhcp-config)#exit
IOU2(config)#ip dhcp pool v10
IOU2(dhcp-config)#network 192.168.10.192 /26
IOU2(dhcp-config)#default-router 192.168.10.254
IOU2(dhcp-config)#dns-server 8.8.8.8
IOU2(dhcp-config)#exit

IOU1上配置中继

IOU1(config)#interface vlan 10         
IOU1(config-if)#ip helper-address 1.1.1.1
IOU1(config-if)#exit
IOU1(config)#interface vlan 11
IOU1(config-if)#ip helper-address 1.1.1.1
IOU1(config-if)#exit
IOU1(config)#interface vlan 12
IOU1(config-if)#ip helper-address 1.1.1.1
IOU1(config-if)#exit
IOU1(config)#interface vlan 13
IOU1(config-if)#ip helper-address 1.1.1.1
IOU1(config-if)#exit

IOU3上配置中继

IOU3(config)#interface vlan 10         
IOU3(config-if)#ip helper-address 1.1.1.1
IOU3(config-if)#exit
IOU3(config)#interface vlan 11
IOU3(config-if)#ip helper-address 1.1.1.1
IOU3(config-if)#exit
IOU3(config)#interface vlan 12
IOU3(config-if)#ip helper-address 1.1.1.1
IOU3(config-if)#exit
IOU3(config)#interface vlan 13
IOU3(config-if)#ip helper-address 1.1.1.1
IOU3(config-if)#exit

在PC上验证结果

MSTP+VRRP+静态路由+子网划分+DHCP综合案例_热备份_12

在PC上使用ping命令测试网络连通性

MSTP+VRRP+静态路由+子网划分+DHCP综合案例_ip地址_13