实验需求

实验使用网段192.168.10.0/24分配IP地址,划分vlan 10~13,每个vlan不超过50台主机,配置MSTP协议实现负载均衡、配置VRRP协议实现网关备份,使用静态路由实现全网互通,在路由器上配置DHCP分发IP地址

实验目的

1、掌握子网划分

2、掌握MSTP协议配置及使用场景

3、掌握VRRP协议配置及使用场景

4、掌握DHCP服务器及中继配置

5、掌握静态路由器的配置及使用场景


实验拓扑图

cisco MSTP+VRRP+静态路由+子网划分+DHCP综合实验_ip地址

ip地址规划

    IOU1

e0/0:172.16.1.2/24

e0/1:172.16.2.2/24

loo0: 1.1.1.1/32


    SW1

vlan10:192.168.10.60/26

vlan11:192.168.10.124/26

vlan12:192.168.10.188/26

vlan13:192.168.10.252/26

vip:192.168.10.62

vip:192.168.10.126

vip:192.168.10.190

vip:192.168.10.254

    SW2

vlan10:192.168.10.61/26

vlan11:192.168.10.125/26

vlan12:192.168.10.189/26

vlan13:192.168.10.253/26

vip:192.168.10.62

vip:192.168.10.126

vip:192.168.10.190

vip:192.168.10.254

配置步骤

1.在交换机之前创建vlan10-13

SW1(config)#vlan 10-13

SW1(config-vlan)#ex


SW2(config)#vlan 10-13

SW2(config-vlan)#ex


SW3(config)#vlan 10-13

SW3(config-vlan)#ex

创建完vlan可以用show vlan 查看结果

cisco MSTP+VRRP+静态路由+子网划分+DHCP综合实验_生成树_02

2.交换机之间配置干道

SW1配置干道

SW1(config)#interface range ethernet 0/0-2

SW1(config-if-range)#switchport trunk

encapsulation dot1q

SW1(config-if-range)#switchport mode trunk

SW1(config-if-range)#ex

SW1(config)#interface range ethernet 0/1-2

SW1(config-if-range)#channel-group 1 mode

on

Creating a port-channel interface

Port-channel 1


SW1(config-if-range)#ex

SW1(config)#interface port-channel 1

SW1(config-if)#switchport trunk

encapsulation dot1q

SW1(config-if)#switchport mode trunk

SW1(config-if)#ex

SW1(config)#

使用show interface trunk查看接口有没有干道,下图可以看到Ee0/0和Po1接口的802.1q封装和trunking干道

cisco MSTP+VRRP+静态路由+子网划分+DHCP综合实验_ip地址_03


SW2配置干道

SW2(config)#interface range ethernet 0/0-2

SW2(config-if-range)#switchport trunk

encapsulation dot1q

SW2(config-if-range)#switchport mode trunk

SW2(config-if-range)#ex

SW2(config)#interface range ethernet 0/1-2

SW2(config-if-range)#channel-group 1 mode

on

Creating a port-channel interface

Port-channel 1


SW2(config-if-range)#ex

SW2(config)#interface port-channel 1

SW2(config-if)#switchport trunk

encapsulation dot1q

SW2(config-if)#switchport mode trunk

SW2(config-if)#

SW2(config-if)#ex

使用show interface trunk查看接口有没有干道,下图可以看到Ee0/0和Po1接口的802.1q封装和trunking干道

cisco MSTP+VRRP+静态路由+子网划分+DHCP综合实验_ip地址_04


SW3配置干道

SW3(config)#interface range ethernet 1/0-1

SW3(config-if-range)#switchport trunk

encapsulation dot1q

SW3(config-if-range)#switchport mode trunk

SW3(config-if-range)#ex

使用show interface trunk查看接口有没有干道,下图可以看到Et1/0和Et1/1接口的802.1q封装和trunking干道

cisco MSTP+VRRP+静态路由+子网划分+DHCP综合实验_优先级_05


3.将接口加入对应的vlan

SW3(config)#interface e0/0

SW3(config-if)#switchport mode access

SW3(config-if)#switchport access vlan 10

SW3(config-if)#ex

SW3(config)#interface e0/1

SW3(config-if)#switchport mode access

SW3(config-if)#switchport access vlan 11

SW3(config-if)#ex

SW3(config)#interface e0/2

SW3(config-if)#switchport mode access

SW3(config-if)#switchport access vlan 12

SW3(config)#interface e0/3

SW3(config-if)#switchport mode access

SW3(config-if)#switchport access vlan 13

SW3(config-if)#ex


4.配置多生成树协议(MSTP)

SW1配置多生成树命令

SW1(config)#spanning-tree mode mst

SW1(config)#spanning-tree mst configuration

SW1(config-mst)#name bdqn

SW1(config-mst)#revision 1

SW1(config-mst)#instance 1 vlan 10-11

SW1(config-mst)#instance 2 vlan 12-13

SW1(config-mst)#ex

SW1(config)#spanning-tree mst 1 root

primary

SW1(config)#spanning-tree mst 2 root

secondary

SW1(config)#


SW2配置多生成树命令

SW2(config)#spanning-tree mode mst

SW2(config)#spanning-tree mst configuration

SW2(config-mst)#name bdqn

SW2(config-mst)#revision 1

SW2(config-mst)#instance 1 vlan 10-11

SW2(config-mst)#instance 2 vlan 12-13

SW2(config-mst)#ex

SW2(config)#spanning-tree mst 1 root

secondary

SW2(config)#spanning-tree mst 2 root

primary

SW2(config)#


SW3配置多生成树命令

SW3(config)#spanning-tree mode mst

SW3(config)#spanning-tree mst configuration

SW3(config-mst)#name bdqn

SW3(config-mst)#revision 1

SW3(config-mst)#instance 1 vlan 10-11

SW3(config-mst)#instance 2 vlan 12-13

SW3(config-mst)#ex


配置完多生成树可以用show spanning-tree mst 1 和 2查看结果

cisco MSTP+VRRP+静态路由+子网划分+DHCP综合实验_优先级_06



5.配置VRRP(热备份路由协议)

SW1热备份路由配置命令

SW1(config)#interface vlan 10

SW1(config-if)#ip address 192.168.10.60

255.255.255.192

SW1(config-if)#vrrp 10 ip 192.168.10.62

SW1(config-if)#vrrp 10 priority 110

SW1(config-if)#vrrp 10 preempt

SW1(config-if)#no shutdown

SW1(config-if)#ex

SW1(config)#interface vlan 11

SW1(config-if)#ip address 192.168.10.124 255.255.255.192

SW1(config-if)#vrrp 10 ip 192.168.10.126

SW1(config-if)#vrrp 10 priority 110

SW1(config-if)#vrrp 10 preempt

SW1(config-if)#no shutdown

SW1(config-if)#ex

SW1(config)#int vlan 12

SW1(config-if)#ip address 192.168.10.188

255.255.255.192

SW1(config-if)#vrrp 10 ip 192.168.10.190

SW1(config-if)#vrrp 10 priority 90

SW1(config-if)#vrrp 10 preempt

SW1(config-if)#no shutdown

SW1(config-if)#ex

SW1(config)#interface vlan 13

SW1(config-if)#ip address 192.168.10.252

255.255.255.192

SW1(config-if)#vrrp 10 ip 192.168.10.254

SW1(config-if)#vrrp 10 priority 90

SW1(config-if)#vrrp 10 preempt

SW1(config-if)#no shutdown

SW1(config-if)#ex

SW1(config)#

SW1(config)#track 100 interface ethernet

0/3 line-protocol

SW1(config-track)#ex

SW1(config)#interface vlan 10

SW1(config-if)#vrrp 10 track 100 decrement

30

SW1(config-if)#ex

SW1(config)#interface vlan 11

SW1(config-if)#vrrp 10 track 100 decrement

30

SW1(config-if)#ex

SW1(config)#

配置完可以用show vrrp brief查看结果

cisco MSTP+VRRP+静态路由+子网划分+DHCP综合实验_ip地址_07


SW2热备份路由配置命令

SW2(config)#interface vlan 10

SW2(config-if)#ip add 192.168.10.61

255.255.255.192

SW2(config-if)#vrrp 10 ip 192.168.10.62

SW2(config-if)#vrrp 10 priority 90

SW2(config-if)#vrrp 10 preempt

SW2(config-if)#no shutdown

SW2(config-if)#ex

SW2(config)#interface vlan 11

SW2(config-if)#ip add 192.168.10.125

255.255.255.192

SW2(config-if)#vrrp 10 ip 192.168.10.126

SW2(config-if)#vrrp 10 priority 90

SW2(config-if)#vrrp 10 preempt

SW2(config-if)#no shutdown

SW2(config-if)#ex

SW2(config)#interface vlan 12

SW2(config-if)#ip add 192.168.10.189

255.255.255.192

SW2(config-if)#vrrp 10 ip 192.168.10.190

SW2(config-if)#vrrp 10 priority 110

SW2(config-if)#vrrp 10 preempt

SW2(config-if)#no shutdown

SW2(config-if)#ex      

SW2(config)#interface vlan 13

SW2(config-if)#ip add 192.168.10.253

255.255.255.192

SW2(config-if)#vrrp 10 ip 192.168.10.254

SW2(config-if)#vrrp 10 priority 110

SW2(config-if)#vrrp 10 preempt

SW2(config-if)#no shut

SW2(config-if)#ex

SW2(config)#track 100 interface ethernet

0/3 line-protocol

SW2(config-track)#ex

SW2(config)#int vlan 12

SW2(config-if)#vrrp 10 track 100 decrement

30

SW2(config-if)#ex

SW2(config)#int vlan 13

SW2(config-if)#vrrp 10 track 100 decrement

30

SW2(config-if)#ex

SW2(config)#

配置完可以用show vrrp brief查看结果

cisco MSTP+VRRP+静态路由+子网划分+DHCP综合实验_优先级_08


6.配置网络设备IP地址

SW1配置IP地址命令

SW1(config)#interface ethernet 0/3

SW1(config-if)#no switchport

SW1(config-if)#ip address 172.16.1.1

255.255.255.0

SW1(config-if)#no shutdown

SW1(config-if)#ex


SW2配置IP地址命令

SW2(config)#interface ethernet 0/3

SW2(config-if)#no switchport

SW2(config-if)#ip address 172.16.2.1

255.255.255.0

SW2(config-if)#no shutdown

SW2(config-if)#ex


IOU1配置IP地址命令

IOU1#conf t

IOU1(config)#interface loopback 0

IOU1(config-if)#ip address 1.1.1.1

255.255.255.255

IOU1(config-if)#ex

IOU1(config)#interface ethernet 0/0

IOU1(config-if)#duplex full

IOU1(config-if)#ip address 172.16.1.2

255.255.255.0

IOU1(config-if)#no shutdown

IOU1(config-if)#ex

IOU1(config)#interface ethernet 0/1

IOU1(config-if)#duplex full

IOU1(config-if)#ip address 172.16.2.2

255.255.255.0

IOU1(config-if)#no shutdown

IOU1(config-if)#ex


7.配置静态路由和浮动路由

IOU1使用了汇总路由和浮动路由

IOU1(config)#ip route 192.168.10.0

255.255.255.128 172.16.1.1

IOU1(config)#ip route 192.168.10.128

255.255.255.128 172.16.2.1

IOU1(config)#ip route 192.168.10.0

255.255.255.128 172.16.2.1 11

IOU1(config)#ip route 192.168.10.128

255.255.255.128 172.16.1.1 11

配置完可以用show ip route查看路由表

cisco MSTP+VRRP+静态路由+子网划分+DHCP综合实验_生成树_09

在SW1上配置默认路由

SW1(config)#ip route 0.0.0.0 0.0.0.0

172.16.1.2

配置完可以用show ip route 查看路由表

cisco MSTP+VRRP+静态路由+子网划分+DHCP综合实验_ip地址_10


在SW2上配置默认路由

SW2(config)#ip route 0.0.0.0 0.0.0.0

172.16.2.2

配置完可以用show ip route 查看路由表

cisco MSTP+VRRP+静态路由+子网划分+DHCP综合实验_优先级_11


8.配置DHCP

IOU1(config)#ip dhcp pool vlan10

IOU1(dhcp-config)#network 192.168.10.0 /26

IOU1(dhcp-config)#default-router

192.168.10.62

IOU1(dhcp-config)#dns-server 8.8.8.8

IOU1(dhcp-config)#ex

IOU1(config)#ip dhcp pool vlan11

IOU1(dhcp-config)#network 192.168.10.64 /26

IOU1(dhcp-config)#default-router

192.168.10.126

IOU1(dhcp-config)#dns-server 8.8.8.8

IOU1(config)#ip dhcp pool vlan 12

IOU1(dhcp-config)#network 192.168.10.128

/26

IOU1(dhcp-config)#default-router

192.168.10.190

IOU1(dhcp-config)#dns-server 8.8.8.8

IOU1(dhcp-config)#ex            

IOU1(config)#ip dhcp pool vlan13

IOU1(dhcp-config)#network 192.168.10.192

/26

IOU1(dhcp-config)#default-router

192.168.10.254

IOU1(dhcp-config)#dns-server 8.8.8.8

IOU1(dhcp-config)#ex

9.配置DHCP中继

SW1(DHCP)中继配置命令

SW1(config)#interface vlan 10

SW1(config-if)#ip helper-address 1.1.1.1

SW1(config-if)#ex

SW1(config)#interface vlan 11

SW1(config-if)#ip helper-address 1.1.1.1

SW1(config-if)#ex

SW1(config)#interface vlan 12

SW1(config-if)#ip helper-address 1.1.1.1

SW1(config-if)#ex

SW1(config)#interface vlan 13

SW1(config-if)#ip helper-address 1.1.1.1

SW1(config-if)#ex


SW2(DHCP)中继配置命令

SW2(config)#interface vlan 10

SW2(config-if)#ip helper-address 1.1.1.1

SW2(config-if)#ex

SW2(config)#interface vlan 11

SW2(config-if)#ip helper-address 1.1.1.1

SW2(config-if)#ex

SW2(config)#interface vlan 12

SW2(config-if)#ip helper-address 1.1.1.1

SW2(config-if)#ex

SW2(config)#interface vlan 13

SW2(config-if)#ip helper-address 1.1.1.1

SW2(config-if)#ex


在PC上验证DHCP能否获取到IP地址

cisco MSTP+VRRP+静态路由+子网划分+DHCP综合实验_ip地址_12

cisco MSTP+VRRP+静态路由+子网划分+DHCP综合实验_ip地址_13

cisco MSTP+VRRP+静态路由+子网划分+DHCP综合实验_ip地址_14

cisco MSTP+VRRP+静态路由+子网划分+DHCP综合实验_ip地址_15


在PC上验证能否ping通外网1.1.1.1

cisco MSTP+VRRP+静态路由+子网划分+DHCP综合实验_生成树_16

cisco MSTP+VRRP+静态路由+子网划分+DHCP综合实验_生成树_17

cisco MSTP+VRRP+静态路由+子网划分+DHCP综合实验_优先级_18

cisco MSTP+VRRP+静态路由+子网划分+DHCP综合实验_生成树_19


在SW1上shutdown掉ethernet0/3接口看会不会减优先级

SW1(config)#interface ethernet 0/3

SW1(config-if)#shutdown

shutdown掉后可以用show vrrp brief查看有没有减优先级

cisco MSTP+VRRP+静态路由+子网划分+DHCP综合实验_生成树_20


在SW上shutdown掉ethernet0/3接口看会不会减优先级

SW2(config)#interface ethernet 0/3

SW2(config-if)#shutdown

shutdown掉后可以用show vrrp brief查看有没有减优先级

cisco MSTP+VRRP+静态路由+子网划分+DHCP综合实验_ip地址_21