POJ 1163.The Triangle-动态规划
原创
©著作权归作者所有:来自51CTO博客作者ZERO一的原创作品,请联系作者获取转载授权,否则将追究法律责任
Time Limit: 1000MS |
|
Memory Limit: 10000K |
Total Submissions: 50122 |
|
Accepted: 30285 |
Description
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.
Input
Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.
Output
Your program is to write to standard output. The highest sum is written as an integer.
Sample Input
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
Sample Output
30
题意就是三角形走左下角或右上角和max,从下往上找,动态规划。
代码:
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int N=100+10;
int main(){
int n,a[N][N];
while(~scanf("%d",&n)){
memset(a,0,sizeof(a));
for(int i=0;i<n;i++){
for(int j=0;j<=i;j++)
scanf("%d",&a[i][j]);
}
for(int i=n-2;i>=0;i--){
for(int j=0;j<=i;j++)
a[i][j]+=max(a[i+1][j],a[i+1][j+1]);
}
printf("%d\n",a[0][0]);
}
return 0;
}