POJ1163 The Triangle 【DP】
转载
The Triangle
Time Limit: 1000MS |
|
Memory Limit: 10000K |
Total Submissions: 36918 |
|
Accepted: 22117 |
Description
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.
Input
Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle,
all integers, are between 0 and 99.
Output
Your program is to write to standard output. The highest sum is written as an integer.
Sample Input
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
Sample Output
30
题意:入门级数塔。
题解:用数组存储起点到任一点的最大值为后面的计算提供便利。
#include <stdio.h>
int dp[102][102];
int max(int a, int b){ return a > b ?
a : b; }
int main()
{
int n, i, j, ans;
scanf("%d", &n);
for(i = 1; i <= n; ++i){
for(j = 1; j <= i; ++j){
scanf("%d", &dp[i][j]);
dp[i][j] += max(dp[i-1][j], dp[i-1][j-1]);
}
}
ans = 0;
for(i = 1; i <= n; ++i)
if(dp[n][i] > ans) ans = dp[n][i];
printf("%d\n", ans);
return 0;
}
本文章为转载内容,我们尊重原作者对文章享有的著作权。如有内容错误或侵权问题,欢迎原作者联系我们进行内容更正或删除文章。