7 3 8 8 1 0 2 7 4 4 4 5 2 6 5 (Figure 1)


Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right. 

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input


5 7 3 8 8 1 0 2 7 4 4 4 5 2 6 5


Sample Output


30


解题思路:

最最最经典的动态规划入门题

初始状态是最后一层的数据,状态转移为一个结点左下方和右下方较大的那个加上结点值

#include <iostream>
#include <algorithm>
using namespace std;
const int MAXN = 110;
//输入数字
int N;
int triArr[MAXN][MAXN];
int stDp[MAXN][MAXN];

int main() {
	cin >> N;
	for (int i = 0; i < N; ++i) {
		for (int j = 0; j <= i; ++j) {
			cin >> triArr[i][j];   //输入结果
		}
	}

	//先把第一阶段的结果进行填充
	for (int k = 0; k < N; ++k) {
		stDp[N - 1][k] = triArr[N - 1][k];  //填充的结果是最后一行
	}

	for (int i = N - 2; i >= 0; --i) {
		for (int j = 0; j <= i; ++j) {
			stDp[i][j] = max(stDp[i+1][j], stDp[i+1][j + 1]) + triArr[i][j];
		}
	}
	cout << stDp[0][0] << endl;

	system("PAUSE");
	return 0;
}