POJ 1163 The Triangle
原创
©著作权归作者所有:来自51CTO博客作者qq636b7aec0b3f1的原创作品,请联系作者获取转载授权,否则将追究法律责任
Description
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.
Input
Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.
Output
Your program is to write to standard output. The highest sum is written as an integer.
Sample Input
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
Sample Output
30
简单dp
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<string>
#include<cmath>
#include<queue>
#include<vector>
#include<map>
#include<set>
using namespace std;
const int maxn = 105;
int n, f[maxn][maxn], a[maxn][maxn];
int main()
{
while (~scanf("%d", &n))
{
memset(f, 0, sizeof(f));
for (int i = 1; i <= n;i++)
for (int j = 1; j <= i; j++) scanf("%d", &a[i][j]);
for (int i = n; i; i--)
for (int j = 1; j <= i; j++)
f[i][j] = a[i][j] + max(f[i + 1][j], f[i + 1][j + 1]);
printf("%d\n", f[1][1]);
}
return 0;
}