The ranklist of PAT is generated from the status list, which shows the scores of the submissions. This time you are supposed to generate the ranklist for PAT.

Input Specification:
Each input file contains one test case. For each case, the first line contains 【PAT (Advanced Level) Practice】1075 PAT Judge (25 分)_i++ positive integers, 【PAT (Advanced Level) Practice】1075 PAT Judge (25 分)_排序_02, the total number of users, 【PAT (Advanced Level) Practice】1075 PAT Judge (25 分)_排序_03, the total number of problems, and 【PAT (Advanced Level) Practice】1075 PAT Judge (25 分)_排序_04, the total number of submissions. It is then assumed that the user id’s are 5-digit numbers from 【PAT (Advanced Level) Practice】1075 PAT Judge (25 分)_#include_05 to 【PAT (Advanced Level) Practice】1075 PAT Judge (25 分)_排序_06, and the problem id’s are from 【PAT (Advanced Level) Practice】1075 PAT Judge (25 分)_sed_07 to 【PAT (Advanced Level) Practice】1075 PAT Judge (25 分)_#include_08. The next line contains 【PAT (Advanced Level) Practice】1075 PAT Judge (25 分)_#include_08 positive integers 【PAT (Advanced Level) Practice】1075 PAT Judge (25 分)_sed_10, where 【PAT (Advanced Level) Practice】1075 PAT Judge (25 分)_i++_11 corresponds to the full mark of the i-th problem. Then 【PAT (Advanced Level) Practice】1075 PAT Judge (25 分)_i++_12 lines follow, each gives the information of a submission in the following format:

user_id problem_id partial_score_obtained

where ​​partial_score_obtained​​​ is either −【PAT (Advanced Level) Practice】1075 PAT Judge (25 分)_sed_07 if the submission cannot even pass the compiler, or is an integer in the range [0, ​​​p[problem_id]​​]. All the numbers in a line are separated by a space.

Output Specification:
For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] ... s[K]

where ​​rank​​​ is calculated according to the ​​total_score​​​, and all the users with the same ​​total_score​​​ obtain the same ​​rank​​​; and ​​s[i]​​​ is the partial score obtained for the ​​i​​-th problem. If a user has never submitted a solution for a problem, then “-” must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id’s. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:

7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0

Sample Output:

1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -

#include<iostream>
#include<algorithm>
#include<unordered_map>
#include<vector>

using namespace std;

const int K = 6;

int n, m, k;
int g[K];

struct Student{

string id;
int grade[K];
int cnt; // 满分数量
int pass_cnt; // 通过编译数
int total_score; // 总分数

Student(){
}

Student(string uid){
id = uid;
for(int i = 0; i <= k; i++) grade[i] = -2;
}

void calc(){
cnt = 0;
total_score = 0;
pass_cnt = 0;
for(int i = 1; i <= k; i++){
if(g[i] == grade[i]) cnt++;
if(grade[i] >= 0) pass_cnt++;
if(grade[i] == -1) grade[i] = 0;
total_score += max(0, grade[i]);
}
}

bool operator < (const Student &t) const{

if(total_score != t.total_score) return total_score > t.total_score;
if(cnt != t.cnt) return cnt > t.cnt;
return id < t.id;
}
};

unordered_map<string, Student> sts;

int main(){

cin >> n >> k >> m;

for(int i = 1; i <= k; i++) cin >> g[i];

while(m--){

string u_id;
int p_id, score;
cin >> u_id >> p_id >> score;

if(!sts.count(u_id)) sts[u_id] = Student(u_id);

auto &t = sts[u_id];

t.grade[p_id] = max(t.grade[p_id], score);
}

vector<Student> vs;

for(auto &item: sts){
auto &s = item.second;
s.calc();
if(s.pass_cnt) vs.push_back(s);
}

sort(vs.begin(), vs.end());

for(int i = 0, rank = 0; i < vs.size(); i++){

if(!i || vs[i].total_score != vs[i-1].total_score) rank = i + 1;

Student &s = vs[i];
cout << rank << ' ' << s.id << ' ' << s.total_score;

for(int j = 1; j <= k; j++)
if(s.grade[j] < 0) cout << " -";
else cout << ' ' << s.grade[j];

cout << endl;
}

return 0;
}