According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Heap sort divides its input into a sorted and an unsorted region, and it iteratively shrinks the unsorted region by extracting the largest element and moving that to the sorted region. it involves the use of a heap data structure rather than a linear-time search to find the maximum.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer 【PAT (Advanced Level) Practice】1098 Insertion or Heap Sort (25 分)_i++. Then in the next line, 【PAT (Advanced Level) Practice】1098 Insertion or Heap Sort (25 分)_插入排序_02 integers are given as the initial sequence. The last line contains the partially sorted sequence of the 【PAT (Advanced Level) Practice】1098 Insertion or Heap Sort (25 分)_插入排序_02 numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print in the first line either “Insertion Sort” or “Heap Sort” to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resulting sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 6 0
6 4 5 1 0 3 2 7 8 9

Sample Output 2:

Heap Sort
5 4 3 1 0 2 6 7 8 9

#include<iostream>
#include<algorithm>

using namespace std;

const int N = 110;

int n;
int a[N], q[N];

void down(int t, int n){

int u = t;
if(t * 2 <= n && q[u] < q[t * 2]) u = 2 * t;
if(t * 2 + 1 <= n && q[u] < q[t * 2 + 1]) u = 2 * t + 1;

if(t != u){
swap(q[u], q[t]);
down(u, n);
}
}

int main(){

cin >> n;
for(int i = 1; i <= n; i++) cin >> a[i];
for(int i = 1; i <= n; i++) cin >> q[i];
// 插入排序:前面已经排序好(非递减顺序),而后面没变
int k = 2;
while(k <= n && q[k] >= q[k - 1]) k++;
int m = k;
while(k <= n && a[k] == q[k]) k++;

if(k == n + 1){ // 插入排序

puts("Insertion Sort");

while(m > 1 && q[m] < q[m - 1]) swap(q[m], q[m - 1]), m--;
//sort(q + 1, q + m + 1);

}else{ // 堆排序:排序好的那些元素一定大于等于堆顶元素

puts("Heap Sort");
m = n;
while(m >= 1 && q[m] >= q[1]) m--;

swap(q[1], q[m]);
down(1, m - 1);
}

cout << q[1];
for(int i = 2; i <= n; i++) cout << ' ' << q[i];

return 0;
}