A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 【PAT (Advanced Level) Practice】1024 Palindromic Number (25 分)_高精度 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 【PAT (Advanced Level) Practice】1024 Palindromic Number (25 分)_sed_02 steps: 【PAT (Advanced Level) Practice】1024 Palindromic Number (25 分)_i++_03, and 【PAT (Advanced Level) Practice】1024 Palindromic Number (25 分)_i++_04.

Given any positive integer 【PAT (Advanced Level) Practice】1024 Palindromic Number (25 分)_高精度_05, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:
Each input file contains one test case. Each case consists of two positive numbers 【PAT (Advanced Level) Practice】1024 Palindromic Number (25 分)_高精度_05 and 【PAT (Advanced Level) Practice】1024 Palindromic Number (25 分)_i++_07, where 【PAT (Advanced Level) Practice】1024 Palindromic Number (25 分)_高精度_08 is the initial numer and 【PAT (Advanced Level) Practice】1024 Palindromic Number (25 分)_i++_09 is the maximum number of steps. The numbers are separated by a space.

Output Specification:
For each test case, output two numbers, one in each line. The first number is the paired palindromic number of 【PAT (Advanced Level) Practice】1024 Palindromic Number (25 分)_高精度_05, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after 【PAT (Advanced Level) Practice】1024 Palindromic Number (25 分)_i++_07 steps, just output the number obtained at the 【PAT (Advanced Level) Practice】1024 Palindromic Number (25 分)_i++_07th step and 【PAT (Advanced Level) Practice】1024 Palindromic Number (25 分)_i++_07 instead.

Sample Input 1:

67 3

Sample Output 1:

484
2

Sample Input 2:

69 3

Sample Output 2:

1353
3

#include<iostream>
#include<vector>

using namespace std;

int k;
string s;

bool check(vector<int> & a){

for(int i = 0, j = a.size() - 1; i < j; i++, j--)
if(a[i] != a[j])
return false;
return true;
}

vector<int> add(vector<int>& a, vector<int>& b){

vector<int> c;

int t = 0;
for(int i = 0; i < a.size() || i < b.size() || t; i++){

if(i < a.size()) t += a[i];
if(i < b.size()) t += b[i];
c.push_back(t % 10);
t /= 10;
}

return c;
}


int main(){

cin >> s >> k;

vector<int> a;
for(int i = s.size() - 1; i >= 0; i--) a.push_back(s[i] - '0');

int cnt = 0;
while(!check(a) && cnt < k){
cnt++;
vector<int> b(a.rbegin(), a.rend());
a = add(a, b);
}

for(int i = a.size() - 1; i >= 0; i--)
cout << a[i];

cout << '\n' << cnt;

return 0;
}