To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: ​​C​​​ - C Programming Language, ​​M​​​ - Mathematics (Calculus or Linear Algrbra), and ​​E​​ - English. At the mean time, we encourage students by emphasizing on their best ranks – that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of ​​C​​​, ​​M​​​, ​​E​​​ and ​​A​​ - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101 98 85 88 90
310102 70 95 88 84
310103 82 87 94 88
310104 91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 2 numbers 【PAT (Advanced Level) Practice】1012 The Best Rank (25 分)_排序 and 【PAT (Advanced Level) Practice】1012 The Best Rank (25 分)_i++_02, which are the total number of students, and the number of students who would check their ranks, respectively. Then 【PAT (Advanced Level) Practice】1012 The Best Rank (25 分)_排序 lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of 【PAT (Advanced Level) Practice】1012 The Best Rank (25 分)_i++_04) of that student in the order of ​​​C​​​, ​​M​​​ and ​​E​​​. Then there are 【PAT (Advanced Level) Practice】1012 The Best Rank (25 分)_排序_05 lines, each containing a student ID.

Output Specification:
For each of the 【PAT (Advanced Level) Practice】1012 The Best Rank (25 分)_排序_05 students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as ​​A​​​ > ​​C​​​ > ​​M​​​ > ​​E​​. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output ​​N/A​​.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A

#include<iostream>
#include<unordered_map>
#include<vector>
#include<cmath>
#include<algorithm>

using namespace std;

unordered_map<string, vector<int>> grades;
vector<int> v[4];
int n, m;

int check(vector<int> & a, int x){

int l = 0, r = a.size() - 1;

while(l < r){
int mid = l + r >> 1;
if(a[mid] <= x) r = mid;
else l = mid + 1;
}

return l + 1;
}

int main(){

cin >> n >> m;

for(int i = 0; i < n; i++){

string id;
int a[4];
cin >> id;

for(int j = 1; j < 4; j++) cin >> a[j];
a[0] = round((a[1] + a[2] + a[3])/3.0);

for(int j = 0; j < 4; j++){
v[j].push_back(a[j]);
grades[id].push_back(a[j]);
}
}

for(int i = 0; i < 4; i++) sort(v[i].begin(), v[i].end(), greater<int>());

string cls = "ACME";
while(m--){

string id;
cin >> id;

if(!grades.count(id)) puts("N/A");
else{

int res = n + 1;
char c;

for(int i = 0; i < 4; i++){

int rk = check(v[i], grades[id][i]);
if(rk < res){

c = cls[i];
res = rk;
}
}

cout << res << ' ' << c << endl;
}
}

return 0;
}