The Triangle

Time Limit: 1000MS Memory Limit: 10000K

Description

7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

(Figure 1)

Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output

30

问题分析

一道很经典的动态规划题。题意就是有一个数字三角形,从顶点(1,1)开始出发,一直走到最底层,每次只能往下走或者右下走,期间会有很多不同大小的数字,求最后走到最底层之后所经过的所有数字之和的最大值。

状态转移方程为dp[i][j] = a[i][j](i==n时);其他情况时:dp[i][j] = max(dp[i+1][j],dp[i+1][j+1])+a[i][j];

首先,看第一种做法,普通递归。

int maxSum(int i, int j)
{
if(i==n)
return a[i][j];
int down = maxSum(i+1,j);
int downRight = maxSum(i+1,j+1);
return a[i][j]+max(down,downRight);
}

结果是…..超时,没错23333。原因是,重复计算。深度遍历每一条路径,时间复杂度为O(2^n),当n为100的时候肯定超时喔。

嗯~那就看看怎么减少重复计算呗。不如,把一些计算结果存起来,采用记忆型递归,这样就不会超时啦~,时间复杂度为O(n^2),因为三角形数字总个数为n*(n+1)/2。

int maxSum(int i, int j)
{
if(i==n)
return a[i][j];
if(dp[i][j]!=0)
return dp[i][j];
int down = maxSum(i+1,j);
int downRight = maxSum(i+1,j+1);
return dp[i][j] = a[i][j]+max(down,downRight);
}

来看第三种做法
递归转递推。

#include <iostream>
#include <algorithm>
using namespace std;
const int N = 111;
int a[N][N], dp[N][N], n;

int main()
{
// freopen("in.txt","r",stdin);
cin >> n;
for(int i = 1; i <= n; i++)
for(int j = 1; j <= i; j++)
cin >> a[i][j];
for(int i = 1; i <= n; i++)
dp[n][i] = a[n][i];
//从底层一行一行向上递推
for(int i = n-1; i >= 1; i--)
for(int j = 1; j <= i; j++)
dp[i][j] = max(dp[i+1][j],dp[i+1][j+1]) + a[i][j];
cout << dp[1][1] << endl;
return 0;
}

但是还木有完喔,想一想,时间基本不可以优化了,空间能不能优化一下呢?
这里是不是也同样满足最优子结构和无后效性呢?
每一步只能往下或者右下走,是不是每一行只有一个唯一的最大值,所以我们没必要用二维数组存储每一步的最大值,只需要一个一维数组dp[101]就可以了。

再进一步想,甚至连dp数组都可以不用,直接用一个指针指向第n行即可。

int *dp = a[n];
for(int i = n-1; i >= 1; i--)
for(int j = 1; j <= i; j++)
dp[j] = max(dp[j],dp[j+1]) + a[i][j];
cout << dp[1] << endl;