欧拉定理
就是a和m互质,且a小于m,设x为欧拉函数的值,则a^x%m=1恒成立。由于题上的说明是a为二
则只要m是奇数,且m不等于1即可

2^x mod n = 1

Problem Description
Give a number n, find the minimum x(x>0) that satisfies 2^x mod n = 1.

Input
One positive integer on each line, the value of n.

Output
If the minimum x exists, print a line with 2^x mod n = 1.

Print 2^? mod n = 1 otherwise.

You should replace x and n with specific numbers.

Sample Input
2
5

Sample Output
2^? mod 2 = 1
2^4 mod 5 = 1

题意 :如果有值就输出,没有则用?代替

代码:

# include <iostream>
# include <cstdio>

int main(){

int n,m;
int i,j,k;

while(scanf("%d",&n)!=EOF){

if(n%2==0||n==1) printf("2^? mod %d = 1\n",n);
else{
int i = 1;
m = 1;
while(1){
m =m*2%n;//数据这样处理防止溢出
if(m==1){printf("2^%d mod %d = 1\n",i,n); break; }
i++;
}



}

}

return 0;
}