Max Sum
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 204780 Accepted Submission(s): 47877
Problem Description
Given
a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max
sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in
this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The
first line of the input contains an integer T(1<=T<=20) which
means the number of test cases. Then T lines follow, each line starts
with a number N(1<=N<=100000), then N integers followed(all the
integers are between -1000 and 1000).
Output
For
each test case, you should output two lines. The first line is "Case
#:", # means the number of the test case. The second line contains three
integers, the Max Sum in the sequence, the start position of the
sub-sequence, the end position of the sub-sequence. If there are more
than one result, output the first one. Output a blank line between two
cases.
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
Sample Output
Case 1:
14 1 4
Case 2:
7 1 6
模板题:
#include <stdio.h>
#include <iostream>
#include <string.h>
#include <math.h>
#include <algorithm>
using namespace std;
const int N = 100005;
int a[N];
int dp[N];
int main()
{
int tcase;
scanf("%d",&tcase);
int k =1;
while(tcase--){
int n;
scanf("%d",&n);
for(int i=1;i<=n;i++){
scanf("%d",&a[i]);
}
int start=1,endd=1,t=1;
int mx = dp[1] = a[1];
for(int i=2;i<=n;i++){
if(dp[i-1]>=0){
dp[i] = dp[i-1]+a[i];
}else{
t = i;
dp[i] = a[i];
}
if(dp[i]>mx){
mx = dp[i];
start = t;
endd = i;
}
}
printf("Case %d:\n%d %d %d\n",k++,mx,start,endd);
if(tcase!=0) printf("\n");
}
return 0;
}