People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 【PAT (Advanced Level) Practice】1027 Colors in Mars (20 分)_进位制-digit number, where the first 【PAT (Advanced Level) Practice】1027 Colors in Mars (20 分)_数学_02 digits are for ​​​Red​​​, the middle 【PAT (Advanced Level) Practice】1027 Colors in Mars (20 分)_数学_02 digits for ​​​Green​​​, and the last 【PAT (Advanced Level) Practice】1027 Colors in Mars (20 分)_数学_02 digits for ​​​Blue​​​. The only difference is that they use radix 【PAT (Advanced Level) Practice】1027 Colors in Mars (20 分)_sed_05 (【PAT (Advanced Level) Practice】1027 Colors in Mars (20 分)_进位制_06 and 【PAT (Advanced Level) Practice】1027 Colors in Mars (20 分)_sed_07) instead of 【PAT (Advanced Level) Practice】1027 Colors in Mars (20 分)_数学_08. Now given a color in three decimal numbers (each between 【PAT (Advanced Level) Practice】1027 Colors in Mars (20 分)_git_09 and 【PAT (Advanced Level) Practice】1027 Colors in Mars (20 分)_git_10), you are supposed to output their Mars RGB values.

Input Specification:

Each input file contains one test case which occupies a line containing the three decimal color values.

Output Specification:

For each test case you should output the Mars RGB value in the following format: first output ​​#​​​, then followed by a 【PAT (Advanced Level) Practice】1027 Colors in Mars (20 分)_进位制-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a ​​​0​​ to its left.

Sample Input:

15 43 71

Sample Output:

#123456

#include<iostream>

using namespace std;

int a[3];

char get(int x){

if(x < 10) return '0' + x;
return x - 10 + 'A';
}

int main(){

for(int i = 0; i < 3; i++) scanf("%d", &a[i]);

cout << '#';

for(int i = 0; i < 3; i++) cout << get(a[i] / 13) << get(a[i] % 13);

return 0;
}