To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish ​​1​​​ (one) from l (​​L​​​ in lowercase), or ​​0​​​ (zero) from ​​O​​​ (​​o​​​ in uppercase). One solution is to replace ​​1​​​ (one) by @, ​​0​​​ (zero) by ​​%​​​, ​​l​​​ by ​​L​​​, and ​​O​​​ by ​​o​​. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:
Each input file contains one test case. Each case contains a positive integer 【PAT (Advanced Level) Practice】1035 Password (20 分)_字符串处理, followed by 【PAT (Advanced Level) Practice】1035 Password (20 分)_#include_02 lines of accounts. Each account consists of a user name and a password, both are strings of no more than 【PAT (Advanced Level) Practice】1035 Password (20 分)_pat甲级_03 characters with no space.

Output Specification:
For each test case, first print the number 【PAT (Advanced Level) Practice】1035 Password (20 分)_pat甲级_04 of accounts that have been modified, then print in the following 【PAT (Advanced Level) Practice】1035 Password (20 分)_pat甲级_04 lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line ​​​There are N accounts and no account is modified​​​ where ​​N​​​ is the total number of accounts. However, if ​​N​​​ is one, you must print ​​There is 1 account and no account is modified​​ instead.

Sample Input 1:

3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa

Sample Output 1:

2
Team000002 RLsp%dfa
Team000001 R@spodfa

Sample Input 2:

1
team110 abcdefg332

Sample Output 2:

There is 1 account and no account is modified

Sample Input 3:

2
team110 abcdefg222
team220 abcdefg333

Sample Output 3:

There are 2 accounts and no account is modified


#include<iostream>

using namespace std;

const int N = 1010;

string name[N], pass[N];

string change(string s){

string res;
for(auto c: s){

if(c == '1') res += '@';
else if(c == '0') res += '%';
else if(c == 'l') res += 'L';
else if(c == 'O') res += 'o';
else res += c;
}
return res;
}

int main(){

int n;
cin >> n;

int m = 0;
for(int i = 0; i < n; i++){

string cur_name, cur_pass;
cin >> cur_name >> cur_pass;

string changed_pass = change(cur_pass);

if(cur_pass != changed_pass){

m++;
name[m] = cur_name;
pass[m] = changed_pass;
}
}

if(!m){

if(n == 1) puts("There is 1 account and no account is modified");
else printf("There are %d accounts and no account is modified\n", n);

}else{

cout << m << endl;
for(int i = 1; i <= m; i++) cout << name[i] << ' ' << pass[i] << endl;
}

return 0;
}