poj 1426 Find The Multiple (BFS)
转载
Find The Multiple
Time Limit: 1000MS |
|
Memory Limit: 10000K |
Total Submissions: 22121 |
|
Accepted: 9081 |
|
Special Judge |
Description
Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0
Sample Output
10
100100100100100100
111111111111111111
Source
Dhaka 2002
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<queue>
using namespace std;
int n;
long long bfs(){
queue<long long >q;
q.push(1);
while(1){
long long temp=q.front();
q.pop();
if(temp%n==0)
return temp;
q.push(temp*10);
q.push(temp*10+1);
}
}
int main(){
//int t;
while(scanf("%d",&n)!=EOF){
if(n==0)
break;
printf("%lld\n",bfs());
}
return 0;
}
本文章为转载内容,我们尊重原作者对文章享有的著作权。如有内容错误或侵权问题,欢迎原作者联系我们进行内容更正或删除文章。