Find The Multiple


Language:Default

Find The Multiple


Time Limit:

Memory Limit:

Total Submissions:

Accepted:

Special Judge

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2 6 19 0

Sample Output

10 100100100100100100 111111111111111111

Source

​Dhaka 2002​

—– 这道题让找 n 的 01 十进制倍数, 也就是说,找出一个01序列,它是 n 的倍数 第一位只能是1 所以就从 1 开始DFS 下一位只能是0或者1 所以说复杂度是

O(2n) O ( 2 n ) 的级别,有点儿不敢写,但是后来发现这个最大也就是 218 2 18 ,能过得 —

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long ll;
ll n,k,flag;
void dfs(ll t,ll i)
{
if(i==19) return ;
if(flag) return ;
if(t%n==0)
{
flag=1;
printf("%lld\n",t);
return ;
}

dfs(t*10,i+1);
dfs(t*10+1,i+1);
}
int main()
{
while(~scanf("%lld",&n)&&n)
{
flag=0;
dfs(1,0);
}
return 0;
}