Some C++ data types, their format specifiers, and their most common bit widths are as follows:

  • Int ("%d"): 32 Bit integer
  • Long ("%ld"): 64 bit integer
  • Char ("%c"): Character type
  • Float ("%f"): 32 bit real value
  • Double ("%lf"): 64 bit real value

Reading
To read a data type, use the following syntax:

scanf("`format_specifier`", &val)

For example, to read a character followed by a double:

char ch;
double d;
scanf("%c %lf", &ch, &d);

For the moment, we can ignore the spacing between format specifiers.


Printing
To print a data type, use the following syntax:

printf("`format_specifier`", val)

For example, to print a character followed by a double:

char ch = 'd';
double d = 234.432;
printf("%c %lf", ch, d);

Note: You can also use cin and cout instead of scanf and printf; however, if you are taking a million numbers as input and printing a million lines, it is faster to use scanf and printf.

Input Format

Input consists of the following space-separated values: intlongcharfloat, and double, respectively.

Output Format

Print each element on a new line in the same order it was received as input. Note that the floating point value should be correct up to 3 decimal places and the double to 9 decimal places.

Sample Input

3 12345678912345 a 334.23 14049.30493

Sample Output

3
12345678912345
a
334.230
14049.304930000

Basic Data Types_基本数据类型

#include<iostream>
#include<iomanip>
using namespace std;
int main()
{
	int a;
	long long b;//变量数据类型的选择:应该使用long long int,又可简写为long long
	char c;
	float d;
	double e;
	cin >> a >> b >> c >> d >> e;
	cout << a << endl;
	cout << b << endl;
	cout << c << endl;
	/*我们在这里主要用到其中两个:fixed 和 showpoint。
首先说fixed,以定点方式显示实数,即显示整数部分*/
	cout <<setiosflags(ios::fixed)<< setprecision(3)<<d<< endl;
	cout<<setiosflags(ios::fixed)<<setprecision(9) <<e;
	return 0;
}

主要考察基本变量吧,注意long long ;