Drainage Ditches


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13696    Accepted Submission(s): 6481


Problem Description


Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 


 



Input


The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.


 



Output


For each case, output a single integer, the maximum rate at which water may emptied from the pond. 


 



Sample Input


5 4 1 2 40 1 4 20 2 4 20 2 3 30 3 4 10


 



Sample Output


50


 



Source


​USACO 93​


 


此题是网络流的入门题,用最基础的EK算法,EK算法很好理解,通过不停得在残留网络中寻找增广路径,再修改残留网络,直到找不到增广路径为止,对于网络流的其他算法小编在之前发的​​ACM_模板_网络流​​中有详细解释。

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std;
const int maxn = 200+2;
const int INF = 0xfffffff;
int capacity[maxn][maxn],flow[maxn],pre[maxn],n,m;
queue<int> q;
int BFS(int src,int des)
{
int i,j;
while(!q.empty())
q.pop();//队列清空
for(i=1; i<=m; i++)
pre[i] = -1;
pre[src] = 0;
flow[src] = INF;
q.push(src);
while(!q.empty())
{
int index = q.front();
q.pop();
if(index == des) break;//找到了增广路径
for(i=1; i<=m; i++)
{
if(i!=src && capacity[index][i]>0 && pre[i]==-1)
{
pre[i] = index;//记录前驱
flow[i] = min(capacity[index][i],flow[index]);
q.push(i);
}
}
}
if(pre[des] == -1) return -1;//残留图中不再存在增广路径
else return flow[des];
}
int maxFlow(int src,int des)
{
int increasement = 0;
int sumflow = 0;
while((increasement = BFS(src,des)) != -1)
{
int k = des;//利用前驱寻找路径
while(k != src)
{
int last = pre[k];
capacity[last][k] -= increasement;//改变正向边的容量
capacity[k][last] += increasement;//改变反向边的容量
k = last;
}
sumflow += increasement;
}
return sumflow;
}
int main()
{
int i,j;
int start,end,ci;
while(scanf("%d%d",&n,&m)!=EOF)
{
memset(capacity,0,sizeof(capacity));
memset(flow,0,sizeof(flow));
for(i=0; i<n; i++)
{
scanf("%d%d%d",&start,&end,&ci);
if(start == end) continue;
capacity[start][end] += ci;
}
printf("%d\n",maxFlow(1,m));
}
return 0;
}