Biorhythms


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2265    Accepted Submission(s): 971


Problem Description


Some people believe that there are three cycles in a person's life that start the day he or she is born. These three cycles are the physical, emotional, and intellectual cycles, and they have periods of lengths 23, 28, and 33 days, respectively. There is one peak in each period of a cycle. At the peak of a cycle, a person performs at his or her best in the corresponding field (physical, emotional or mental). For example, if it is the mental curve, thought processes will be sharper and concentration will be easier. 

Since the three cycles have different periods, the peaks of the three cycles generally occur at different times. We would like to determine when a triple peak occurs (the peaks of all three cycles occur in the same day) for any person. For each cycle, you will be given the number of days from the beginning of the current year at which one of its peaks (not necessarily the first) occurs. You will also be given a date expressed as the number of days from the beginning of the current year. You task is to determine the number of days from the given date to the next triple peak. The given date is not counted. For example, if the given date is 10 and the next triple peak occurs on day 12, the answer is 2, not 3. If a triple peak occurs on the given date, you should give the number of days to the next occurrence of a triple peak. 


This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.


 



Input


You will be given a number of cases. The input for each case consists of one line of four integers p, e, i, and d. The values p, e, and i are the number of days from the beginning of the current year at which the physical, emotional, and intellectual cycles peak, respectively. The value d is the given date and may be smaller than any of p, e, or i. All values are non-negative and at most 365, and you may assume that a triple peak will occur within 21252 days of the given date. The end of input is indicated by a line in which p = e = i = d = -1. 


 



Output


For each test case, print the case number followed by a message indicating the number of days to the next triple peak, in the form: 

Case 1: the next triple peak occurs in 1234 days.

Use the plural form ``days'' even if the answer is 1. 


 



Sample Input


1 0 0 0 0 0 0 0 100 5 20 34 325 4 5 6 7 283 102 23 320 203 301 203 40 -1 -1 -1 -1


 



Sample Output


Case 1: the next triple peak occurs in 21252 days. Case 2: the next triple peak occurs in 21152 days. Case 3: the next triple peak occurs in 19575 days. Case 4: the next triple peak occurs in 16994 days. Case 5: the next triple peak occurs in 8910 days. Case 6: the next triple peak occurs in 10789 days.


 



Source


​East Central North America 1999; Pacific Northwest 1999​


 


题意:人的一身有三个轮回(纳尼……),周期分别为23、28、33,已知某一年,三个周期的峰值分别是一年的第p、e、i天,请问从第d天开始的第一个满足三个周期的都达到峰值还有多少天。

此题是最基础的中国剩余定理,由于23、28、33是互质的,所以我们直接套用​​中国剩余定理的互质模板​​就可以搞定这道题。


#include <cstdio>
int exGcd(int a,int b,int &x,int &y)
{
if(b == 0)
{
x = 1,y = 0;
return a;
}
int d = exGcd(b,a%b,y,x);
y -= a/b*x;
return d;
}
int Chinese_Remainder(int mod[],int prime[],int len)
{
int i,d,x,y,m,n,ret;
ret = 0,n = 1;
for(i=0; i<len; i++) n *= prime[i];
for(i=0; i<len; i++)
{
m = n/prime[i];
d = exGcd(prime[i],m,x,y);
ret = (ret+y*m*mod[i])%n;
}
return (n+ret%n)%n;
}
int main()
{
int n,i,c,d,C=1,ans;
int mod[15],prime[15] = {23,28,33};
scanf("%d",&c);
while(scanf("%d",&mod[0])!=EOF)
{
for(i=1; i<3; i++) scanf("%d",&mod[i]);
scanf("%d",&d);
if(mod[0] == -1 && mod[1] == -1 && mod[2] == -1) break;
mod[0] %= 23;
mod[1] %= 28;
mod[2] %= 33;
ans = Chinese_Remainder(mod,prime,3);
ans -= d;
if(ans <= 0) ans += 21252;
printf("Case %d: the next triple peak occurs in %d days.\n", C++,ans);
}
return 0;
}