!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Serial0
ip address 192.168.1.1 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint
frame-relay map ip 192.168.1.2 100
frame-relay map ip 192.168.1.3 200 //这两句在这里可以不用配置,因为点到多点,就像是多个点到点的集合,不像MA一样,存在下一跳不可达的问题
router ospf 1
network 1.1.1.1 0.0.0.0 area 0
network 192.168.1.0 0.0.0.255 area 0
3.3.3.3 0 FULL/ - 0:00:31 192.168.1.3 Serial0
2.2.2.2 0 FULL/ - 0:00:35 192.168.1.2 Serial0
C 1.1.1.1 is directly connected, Loopback0
2.0.0.0 255.255.255.255 is subnetted, 1 subnets
O 2.2.2.2 [110/65] via 192.168.1.2, 00:00:50, Serial0
3.0.0.0 255.255.255.255 is subnetted, 1 subnets
O 3.3.3.3 [110/65] via 192.168.1.3, 00:00:50, Serial0
192.168.1.0 is variably subnetted, 3 subnets, 2 masks
C 192.168.1.0 255.255.255.0 is directly connected, Serial0
O 192.168.1.3 255.255.255.255
[110/64] via 192.168.1.3, 00:00:50, Serial0
O 192.168.1.2 255.255.255.255
[110/64] via 192.168.1.2, 00:00:50, Serial0
!
!
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Serial1
ip address 192.168.1.2 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint
frame-relay map ip 192.168.1.1 100 broadcast //在这里可以不用配置,但是如果要静态配置,必须指定为broadcast,因为是一个点对多点的网络类型
!
router ospf 1
network 2.2.2.2 0.0.0.0 area 0
network 192.168.1.0 0.0.0.255 area 0
hostname R3
!
!
no ip domain-lookup
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Serial1
ip address 192.168.1.3 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint
frame-relay map ip 192.168.2.1 200 broadcast
!
router ospf 1
network 3.3.3.3 0.0.0.0 area 0
network 192.168.1.0 0.0.0.255 area 0