FR实验
 
实验目的:今天突然想到很久没做过FR的实验,就顺手把FR的实验做了下  就当是做一个复习  有什么不对的地方 请大家帮忙指出来
 
一:总拓扑
这个拓扑是有用到的只是 R1 R2R3三个路由器
 
实验一:帧中继点到点子接口
 
R1
!
interface Serial2/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 no frame-relay inverse-arp
!
interface Serial2/0.1 point-to-point
 ip address 12.12.12.1 255.255.255.0
 frame-relay interface-dlci 102  
!
interface Serial2/0.2 point-to-point
 ip address 13.13.13.1 255.255.255.0
 frame-relay interface-dlci 103  
 
 
R2
!
interface Serial2/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 no frame-relay inverse-arp
!
interface Serial2/0.1 point-to-point
 ip address 12.12.12.2 255.255.255.0
 frame-relay interface-dlci 201  
!
interface Serial2/0.2 point-to-point
 ip address 23.23.23.2 255.255.255.0
 frame-relay interface-dlci 203  
!
 
R3
 
 
interface Serial2/0
 no ip address
 serial restart-delay 0
!
interface Serial2/0.1 point-to-point
 ip address 13.13.13.3 255.255.255.0
 frame-relay interface-dlci 301  
!
interface Serial2/0.2 point-to-point
 ip address 23.23.23.3 255.255.255.0
 
 
 
 
 
 
三:解释
在这里 首先要在接口下开启帧中继encapsulation frame-relay 但是不要配置ip地址 取消反向arp --no frame-relay inverse-arp
 
接下来就在各个子接口下配置ip 和配置dlci ---frame-relay interface-dlci XX 在这里值得说明的一点是 每个子接口对应的端口地址要在同一网段中
 
 
实验二:帧中继点到多点子接口和点到点子接口相混合
一:实验环境
1R1上起两个子接口s2/0.1 ,s2/0.2  R2 R3 R4各起一个子接口 s2/0.1 同时R1s2/0.1分别与R2 R4s2/0.1做点到多点连接 网段为124.1.1.0/24R1s2/0.2R3s2/0.1 做点到点相连 网段为:13.13.13.0/24
2)在R1 R2 R4上各起一个loopback0 ,起协议为ospf R1R3上再起一个rip协议 最后做重发布
 
二:配置
 
R1
 
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Serial2/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 no frame-relay inverse-arp
!
interface Serial2/0.1 multipoint
 ip address 124.1.1.1 255.255.255.0
 ip ospf network point-to-multipoint
 frame-relay map ip 124.1.1.2 102 broadcast
 frame-relay map ip 124.1.1.4 104 broadcast
!
interface Serial2/0.2 point-to-point
 ip address 13.13.13.1 255.255.255.0
 frame-relay interface-dlci 103  
!
 
!
router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 no auto-cost
 redistribute rip subnets
 network 1.1.1.1 0.0.0.0 area 0
 network 124.1.1.1 0.0.0.0 area 0
!
router rip
 redistribute ospf 1 metric 10
 network 13.0.0.0
no auto-summary
 
R2:
 
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface Serial2/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 no frame-relay inverse-arp
!
interface Serial2/0.1 multipoint
 ip address 124.1.1.2 255.255.255.0
 ip ospf network point-to-multipoint
 frame-relay map ip 124.1.1.4 204 broadcast
 frame-relay map ip 124.1.1.1 201 broadcast
!
router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
 network 2.2.2.2 0.0.0.0 area 0
 network 124.1.1.2 0.0.0.0 area 0
!
 
R3
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface Serial2/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 no frame-relay inverse-arp
!
interface Serial2/0.1 point-to-point
 ip address 13.13.13.3 255.255.255.0
 frame-relay interface-dlci 301  
!
!
router rip
 network 3.0.0.0
 network 13.0.0.0
no auto-summary
 
R4
 
!
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
!
interface Serial2/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 no frame-relay inverse-arp
 frame-relay lmi-type ansi
!
interface Serial2/0.1 multipoint
 ip address 124.1.1.4 255.255.255.0
 ip ospf network point-to-multipoint
 frame-relay map ip 124.1.1.2 402 broadcast
 frame-relay map ip 124.1.1.1 401 broadcast
!
router ospf 1
 router-id 4.4.4.4
 log-adjacency-changes
 network 4.4.4.4 0.0.0.0 area 0
 network 124.1.1.4 0.0.0.0 area 0
 
 
三:解释
1)在配置帧中继的时候要主要的一点就是类型 lmi  cisco里面 默认的类型都是为cisco 类型是可以改的 一般配置的时候我都是会将类型统一为国际标准 frame-relay lmi-type ansi 排错的时候可以用到的命令为sh frame-relay lmi
 
show frame-relay pvc
show fram map
2)配置协议的时候,像ospf就比较特殊必须在接口下输入ip ospf network point-to-multipoint来修改接口的类型  如果这条命令不打进去 show ip route的时候看不到其他路由器的路由
   
完整的路由应该为
 
 
协议排错命令可以为
sh ip os neighbor
Sh ip ospf interface