RA(config)#interface Loopback0
RA(config-if)#ip address 1.1.1.1 255.255.255.0
RA(config-if)#ip ospf network point-to-point
RA(config-if)#exit
RA(config)#interface Serial1/0
RA(config-if)#ip address 10.10.10.1 255.255.255.0
RA(config-if)#no shutdown
RA(config-if)#exit
RA(config)#router ospf 10
RA(config-router)#router-id 1.1.1.1
RA(config-router)#network 1.1.1.0 0.0.0.255 area 0
RA(config-router)#network 10.10.10.0 0.0.0.255 area 0
RA(config-router)#exit
RB(config)#interface Loopback0
RB(config-if)#ip address 2.2.2.2 255.255.255.0
RB(config-if)#ip ospf network point-to-point
RB(config-if)#exit
RB(config)#interface Serial1/0
RB(config-if)#ip address 10.10.10.2 255.255.255.0
RB(config-if)#no shutdown
RB(config-if)#exit
RB(config)#interface Serial1/1
RB(config-if)#ip address 10.10.20.1 255.255.255.0
RB(config-if)#no shutdown
RB(config-if)#exit
RB(config)#router ospf 20
RB(config-router)#router-id 2.2.2.2
RB(config-router)#network 2.2.2.0 0.0.0.255 area 1
RB(config-router)#network 10.10.20.0 0.0.0.255 area 1
RB(config-router)#network 10.10.10.0 0.0.0.255 area 0
RB(config-router)#exit
RC(config)#interface Loopback0
RC(config-if)#ip address 3.3.3.3 255.255.255.0
RC(config-if)#ip ospf network point-to-point
RC(config-if)#exit
RC(config)#interface Serial1/1
RC(config-if)#ip address 10.10.20.2 255.255.255.0
RC(config-if)#no shutdown
RC(config-if)#exit
RC(config)#router ospf 30
RC(config-router)#router-id 3.3.3.3
RC(config-router)#network 3.3.3.0 0.0.0.255 area 2
RC(config-router)#network 10.10.20.0 0.0.0.255 area 1
RC(config-router)#exit
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
C 1.1.1.0 is directly connected, Loopback0
2.0.0.0/24 is subnetted, 1 subnets
O IA 2.2.2.0 [110/65] via 10.10.10.2, 00:00:07, Serial1/0
10.0.0.0/24 is subnetted, 2 subnets
C 10.10.10.0 is directly connected, Serial1/0
O IA 10.10.20.0 [110/128] via 10.10.10.2, 00:00:07, Serial1/0
RB(config-router)#area 1 virtual-link 3.3.3.3
RB(config-router)#exit
RC(config-router)#area 1 virtual-link 2.2.2.2
RC(config-router)#exit
2.0.0.0/24 is subnetted, 1 subnets
O IA 2.2.2.0 [110/65] via 10.10.10.2, 00:03:18, Serial1/0
3.0.0.0/24 is subnetted, 1 subnets
O IA 3.3.3.0 [110/129] via 10.10.10.2, 00:03:18, Serial1/0
10.0.0.0/24 is subnetted, 2 subnets
O IA 10.10.20.0 [110/128] via 10.10.10.2, 00:03:18, Serial1/0
Virtual Link OSPF_VL0 to router 3.3.3.3 is up ----通往router 3.3.3.3的虚链路已开通。
Run as demand circuit
DoNotAge LSA allowed.
Transit area 1, via interface Serial1/1, Cost of using 64
Transmit Delay is 1 sec, State POINT_TO_POINT, ----点到点的连接。
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:01
Adjacency State FULL (Hello suppressed)
Index 2/3, retransmission queue length 0, number of retransmission 1
First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
Last retransmission scan length is 1, maximum is 1
Last retransmission scan time is 0 msec, maximum is 0 msec
RC#show ip ospf virtual-link
Virtual Link OSPF_VL1 to router 2.2.2.2 is up
Run as demand circuit
DoNotAge LSA allowed.
Transit area 1, via interface Serial1/1, Cost of using 64
Transmit Delay is 1 sec, State POINT_TO_POINT,
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:09
Adjacency State FULL (Hello suppressed)
Index 1/2, retransmission queue length 0, number of retransmission 0
First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
Last retransmission scan length is 0, maximum is 0
Last retransmission scan time is 0 msec, maximum is 0 msec
1.1.1.1 1.1.1.1 684 0x80000009 0x00EA50 3
2.2.2.2 2.2.2.2 1110 0x80000006 0x00398C 3
3.3.3.3 3.3.3.3 2 (DNA) 0x80000001 0x00E6BF 1
2.2.2.0 2.2.2.2 546 0x80000002 0x000D20
2.2.2.0 3.3.3.3 2 (DNA) 0x80000001 0x007376
3.3.3.0 3.3.3.3 2 (DNA) 0x80000001 0x00CC5A
10.10.20.0 2.2.2.2 1047 0x80000003 0x00F3D6
10.10.20.0 3.3.3.3 2 (DNA) 0x80000001 0x00D9EE
1.1.1.1 1.1.1.1 161 0x80000009 0x00EA50 3
2.2.2.2 2.2.2.2 585 0x80000006 0x00398C 3
3.3.3.3 3.3.3.3 1 (DNA) 0x80000001 0x00E6BF 1
2.2.2.0 2.2.2.2 20 0x80000002 0x000D20
2.2.2.0 3.3.3.3 1 (DNA) 0x80000001 0x007376
3.3.3.0 3.3.3.3 1 (DNA) 0x80000001 0x00CC5A
10.10.20.0 2.2.2.2 522 0x80000003 0x00F3D6
10.10.20.0 3.3.3.3 1 (DNA) 0x80000001 0x00D9EE
2.2.2.2 2.2.2.2 20 0x80000009 0x0052C4 3
3.3.3.3 3.3.3.3 429 0x80000008 0x00CF5A 2
1.1.1.0 2.2.2.2 25 0x80000002 0x00B33C
1.1.1.0 3.3.3.3 583 0x80000001 0x001A92
3.3.3.0 3.3.3.3 593 0x80000001 0x00CC5A
10.10.10.0 2.2.2.2 1284 0x80000003 0x006272
10.10.10.0 3.3.3.3 583 0x80000001 0x00CAC7
1.1.1.1 1.1.1.1 1423 (DNA) 0x80000008 0x00EC4F 3
2.2.2.2 2.2.2.2 5 (DNA) 0x80000006 0x00398C 3
3.3.3.3 3.3.3.3 1183 0x80000001 0x00E6BF 1
2.2.2.0 2.2.2.2 1294 (DNA) 0x80000001 0x000F1F
2.2.2.0 3.3.3.3 1183 0x80000001 0x007376
3.3.3.0 3.3.3.3 1183 0x80000001 0x00CC5A
10.10.20.0 2.2.2.2 1967 (DNA) 0x80000002 0x00F5D5
10.10.20.0 3.3.3.3 1183 0x80000001 0x00D9EE
2.2.2.2 2.2.2.2 619 0x80000009 0x0052C4 3
3.3.3.3 3.3.3.3 1025 0x80000008 0x00CF5A 2
1.1.1.0 2.2.2.2 620 0x80000002 0x00B33C
1.1.1.0 3.3.3.3 1175 0x80000001 0x001A92
3.3.3.0 3.3.3.3 1186 0x80000001 0x00CC5A
10.10.10.0 2.2.2.2 1879 0x80000003 0x006272
10.10.10.0 3.3.3.3 1176 0x80000001 0x00CAC7
3.3.3.3 3.3.3.3 1186 0x80000005 0x0059B2 1
1.1.1.0 3.3.3.3 1177 0x80000001 0x001A92
2.2.2.0 3.3.3.3 1188 0x80000001 0x007376
10.10.10.0 3.3.3.3 1178 0x80000001 0x00CAC7
10.10.20.0 3.3.3.3 1188 0x80000001 0x00D9EE
LS age: 1 (DoNotAge)
Options: (No TOS-capability, DC)
LS Type: Router Links
Link State ID: 3.3.3.3
Advertising Router: 3.3.3.3
LS Seq Number: 80000001
Checksum: 0xE6BF
Length: 36
Area Border Router
Number of Links: 1
(Link ID) Neighboring Router ID: 2.2.2.2
(Link Data) Router Interface address: 10.10.20.2
Number of TOS metrics: 0
TOS 0 Metrics: 64
RC#show ip ospf database router 2.2.2.2
LS age: 5 (DoNotAge)
Options: (No TOS-capability, DC)
LS Type: Router Links
Link State ID: 2.2.2.2
Advertising Router: 2.2.2.2
LS Seq Number: 80000006
Checksum: 0x398C
Length: 60
Area Border Router
Number of Links: 3
(Link ID) Neighboring Router ID: 3.3.3.3
(Link Data) Router Interface address: 10.10.20.1
Number of TOS metrics: 0
TOS 0 Metrics: 64