Big Number

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 16   Accepted Submission(s) : 11

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description


As we know, Big Number is always troublesome. But it's really important in our ACM. And today, your task is to write a program to calculate A mod B.

To make the problem easier, I promise that B will be smaller than 100000.

Is it too hard? No, I work it out in 10 minutes, and my program contains less than 25 lines.


Input


The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file.


Output


For each test case, you have to ouput the result of A mod B.


Sample Input


2 3 12 7 152455856554521 3250


Sample Output


2 5 1521


Author


Ignatius.L


Source


杭电ACM省赛集训队选拔赛之热身赛


 


题目大意:求两个数的余数,因为数比较大所以我们不可以直接用a%b的方法,回想一下中学时我们求大数相除的余数时的方法,先用说的最高位去除除数求余数,然后用余数乘以十加被除数的下一位然后再初除数依次进行下去,直到加到最后一位再求得的余数便是最后结果。


代码:


#include <iostream>
#include <cstdio>  
#include <cstring>  
using namespace std;  
#define max 100010  
int main()  
{  
    char str[max];  
    int m,l,sum;  
    while(scanf("%s%d",str,&m)!=EOF)  
    {  
        l=strlen(str);  
        sum=0;  
        for(int i=0;i<l;i++)  
        sum=(sum*10+(str[i]-'0')%m)%m;  
        cout<<sum<<endl;  
    }  
    return 0;
}