题目:
Description
As we know, Big Number is always troublesome. But it's really important in our ACM. And today, your task is to write a program to calculate A mod B.
To make the problem easier, I promise that B will be smaller than 100000.
Is it too hard? No, I work it out in 10 minutes, and my program contains less than 25 lines.
Input
The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file.
Output
For each test case, you have to ouput the result of A mod B.
Sample Input
2 3
12 7
152455856554521 3250
Sample Output
2
5
1521
这个题目很简单,就是输入a,b 输出a%b
因为a很大,所以要用到Java的大数类
代码:
import java.util.*;
import java.math.BigInteger;
public class Main {
public static void main(String[] args) {
Scanner cin = new Scanner(System.in);
String s;
while(cin.hasNext())
{
s=cin.next();
BigInteger a=new BigInteger(s);
s=cin.next();
BigInteger b=new BigInteger(s);
a=a.mod(b);
System.out.println(a.toString());
}
}
}