Big Number


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7103    Accepted Submission(s): 4898


Problem Description


As we know, Big Number is always troublesome. But it's really important in our ACM. And today, your task is to write a program to calculate A mod B.
To make the problem easier, I promise that B will be smaller than 100000.
Is it too hard? No, I work it out in 10 minutes, and my program contains less than 25 lines.


Input

The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file.



Output

For each test case, you have to ouput the result of A mod B.


Sample Input


2 3
12 7
152455856554521 3250


Sample Output


2
5
1521


Author

Ignatius.L

Source

​杭电ACM省赛集训队选拔赛之热身赛 ​



Recommend


Eddy   |   We have carefully selected several similar problems for you:  ​​1215​​​ ​​1211​​​ ​​1210​​​ ​​1214​​​ ​​1213​​ 


题意:大数求模。

题解:看代码吧。。。


AC代码:

#include <stdio.h>
#include<string.h>
#include <stdlib.h>
#define N 50000
char s[N];
int main()
{
int mod,m;
while(~scanf("%s %d",s,&m))
{
mod=0;
for(int i=0;i<strlen(s);i++)
mod=(mod*10+s[i]-'0')%m;
printf("%d\n",mod);
}
return 0;
}



 WA,爆LL


WA代码:


#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<math.h>
using namespace std;
typedef long long LL;

int mod(LL a, LL b)
{
int ans=a;
while(a>b)
{
a=a%b;
ans=a;
}
return ans;
}

int main()
{
ios::sync_with_stdio(false);
LL n,m;
int res;
while(cin>>n>>m)
{
res=mod(n,m);
printf("%d\n",res);
}
return 0;
}