逃离迷宫


Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 19664    Accepted Submission(s): 4791



Problem Description


  给定一个m × n (m行, n列)的迷宫,迷宫中有两个位置,gloria想从迷宫的一个位置走到另外一个位置,当然迷宫中有些地方是空地,gloria可以穿越,有些地方是障碍,她必须绕行,从迷宫的一个位置,只能走到与它相邻的4个位置中,当然在行走过程中,gloria不能走到迷宫外面去。令人头痛的是,gloria是个没什么方向感的人,因此,她在行走过程中,不能转太多弯了,否则她会晕倒的。我们假定给定的两个位置都是空地,初始时,gloria所面向的方向未定,她可以选择4个方向的任何一个出发,而不算成一次转弯。gloria能从一个位置走到另外一个位置吗?


 



Input


  第1行为一个整数t (1 ≤ t ≤ 100),表示测试数据的个数,接下来为t组测试数据,每组测试数据中,
  第1行为两个整数m, n (1 ≤ m, n ≤ 100),分别表示迷宫的行数和列数,接下来m行,每行包括n个字符,其中字符'.'表示该位置为空地,字符'*'表示该位置为障碍,输入数据中只有这两种字符,每组测试数据的最后一行为5个整数k, x 1, y 1, x 2, y 2 (1 ≤ k ≤ 10, 1 ≤ x 1, x 2 ≤ n, 1 ≤ y 1, y 2 ≤ m),其中k表示gloria最多能转的弯数,(x 1, y 1), (x 2, y 2)表示两个位置,其中x 1,x 2对应列,y 1, y 2对应行。


 



Output


  每组测试数据对应为一行,若gloria能从一个位置走到另外一个位置,输出“yes”,否则输出“no”。


 



Sample Input


2 5 5 ...** *.**. ..... ..... *.... 1 1 1 1 3 5 5 ...** *.**. ..... ..... *.... 2 1 1 1 3


 



Sample Output


no yes


#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;
struct zz
{
	int x,y;
}f1,f2;
char a[110][110];
int b[110][110];
int n,m,k,bx,by,ex,ey;
int dx[4]={0,0,1,-1};
int dy[4]={1,-1,0,0};
int bfs(int x,int y)
{
	queue<zz>q;
	memset(b,-1,sizeof(b));	
	f1.x=x;f1.y=y;
	q.push(f1);
	while(!q.empty())
	{
		f1=q.front();
		q.pop();
		for(int i=0;i<4;i++)
		{
			f2.x=f1.x+dx[i];
			f2.y=f1.y+dy[i];
			while(f2.x>0&&f2.x<=n&&f2.y>0&&f2.y<=m&&a[f2.x][f2.y]!='*')
			{
				if(b[f2.x][f2.y]==-1)//第一个拐弯不算,所以从-1开始 
				{					
					b[f2.x][f2.y]=b[f1.x][f1.y]+1;//对还没走过的点,其拐弯次数等于起点的拐弯次数加1. 
					q.push(f2);
					if(f2.x==ex&&f2.y==ey)
						return 1;
				}
				f2.x+=dx[i];f2.y+=dy[i];//重点,向同一个方向一直走,直到走不动为止 
			}
		}		
	} 
	return 0;
}
int main(){
	int t;
	while(scanf("%d",&t)!=EOF)
	{
		while(t--)
		{			
			scanf("%d%d",&n,&m);
			int i;
			for(i=1;i<=n;i++)
				scanf("%s",a[i]+1);
			scanf("%d%d%d%d%d",&k,&by,&bx,&ey,&ex);
			if(bx==ex&&by==ey)
			{
				printf("yes\n");
				continue;
			}
			if(bfs(bx,by))
			{
				if(b[ex][ey]<=k)
					printf("yes\n");
				else
					printf("no\n");
			}
			else
				printf("no\n");
		}
	}
	return 0;
}