Parallelogram Counting


Time Limit: 5000MS

 

Memory Limit: 65536K

Total Submissions: 6004

 

Accepted: 2039


Description


There are n distinct points in the plane, given by their integer coordinates. Find the number of parallelograms whose vertices lie on these points. In other words, find the number of 4-element subsets of these points that can be written as {A, B, C, D} such that AB || CD, and BC || AD. No four points are in a straight line.


Input


The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases. It is followed by the input data for each test case.
The first line of each test case contains an integer n (1 <= n <= 1000). Each of the next n lines, contains 2 space-separated integers x and y (the coordinates of a point) with magnitude (absolute value) of no more than 1000000000.


Output


Output should contain t lines.
Line i contains an integer showing the number of the parallelograms as described above for test case i.


Sample Input


2
6
0 0
2 0
4 0
1 1
3 1
5 1
7
-2 -1
8 9
5 7
1 1
4 8
2 0
9 8


Sample Output


5 6


 


#include<memory.h>
#include<stdlib.h>
#include<stdio.h>
#define MAX 1000
#define HMAX  0x3fffff
#define P 0x1fffff
//将每个中点的x,y都记录下来,如果
//同时记录拥有这个中点的线段的个数
struct Point{
	int x;
	int y;
	int count;
	int next;
};
Point p[MAX*MAX];
int head[HMAX];
int x[MAX],y[MAX];
int main()
{
	int t,n;
	int zz,xx,yy,xtmp,ytmp,top,res,h;
	bool flag;
	scanf("%d",&t);
	while(t--)
	{		
		res = 0;
		top = 0;
		memset(head,-1,sizeof(head));
		memset(p,0,sizeof(p));
		scanf("%d",&n);
		for(int i = 0; i < n; i++)
		{
			scanf("%d%d",&xtmp,&ytmp);
			for(int j = 0; j < i; j++)
			{
				flag = true;
				xx = xtmp + x[j];
				yy = ytmp + y[j];
				//哈希中点坐标之和
				h = abs(xx + yy)%HMAX;
				for(zz=head[h];zz!=-1;zz=p[zz].next)
				{
					if(p[zz].x == xx && p[zz].y == yy)
					{
						p[zz].count++;
						res+=p[zz].count;
						flag = false;
						break;
					}
				}
				//插入新的中点
				if(flag)	
				{
					p[top].x = xx;
					p[top].y = yy;
					p[top].next = head[h];
					head[h] = top++;
				}
			}
			x[i] = xtmp;
			y[i] = ytmp;
		}
		printf("%d\n",res);
	}
	return 0;
}


//又写了一遍

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define N 100003
#define INF 0x3f3f3f3f
using namespace std;
struct pp
{
	int x;
	int y;
	int count;
	int next;
}p[1000010];
int head[N],top;
int x[N],y[N];
int main()
{
	int n,t,i,j,k;
	int x1,y1,xx,yy;
	int h;
	bool flag;
	scanf("%d",&t);
	while(t--)
	{
		top=0;
		memset(head,-1,sizeof(head));
		memset(p,0,sizeof(p));
		scanf("%d",&n);
		int res=0;
		for(k=1;k<=n;k++)
		{
			scanf("%d%d",&x1,&y1);
			for(j=1;j<k;j++)
			{
				flag=true;
				xx=x1+x[j];
				yy=y1+y[j];
				h=abs(xx+yy)%N;
				for(i=head[h];i!=-1;i=p[i].next)
				{
					if(p[i].x==xx&&p[i].y==yy)
					{
						p[i].count++;
						res+=p[i].count;
						flag=false;
						break;
					}
				}
				if(flag)
				{
					p[top].x=xx;
					p[top].y=yy;
					p[top].next=head[h];
					head[h]=top++;
				}
			}
			x[k]=x1;
			y[k]=y1;
		}
		printf("%d\n",res);
	}
	return 0;
}