Parallelogram Counting

Description

There are n distinct points in the plane, given by their integer coordinates. Find the number of parallelograms whose vertices lie on these points. In other words, find the number of 4-element subsets of these points that can be written as {A, B, C, D} such that AB || CD, and BC || AD. No four points are in a straight line.

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases. It is followed by the input data for each test case. 
The first line of each test case contains an integer n (1 <= n <= 1000). Each of the next n lines, contains 2 space-separated integers x and y (the coordinates of a point) with magnitude (absolute value) of no more than 1000000000. 

Output

Output should contain t lines. 
Line i contains an integer showing the number of the parallelograms as described above for test case i. 

Sample Input

2
6
0 0
2 0
4 0
1 1
3 1
5 1
7
-2 -1
8 9
5 7
1 1
4 8
2 0
9 8

Sample Output

5
6

Source

​Tehran Sharif 2004 Preliminary​

Time Limit: 5000MS

 

Memory Limit: 65536K

Total Submissions: 6969

 

Accepted: 2446

题意:n个点,求出这n个点能够组成平行四边形的个数。

分析:

  1.  如果有两条不同线段的中点相交,就是一个平行四边形。
  2. 求出所有线段中点的集合,求出同个中点的出现的个数k。对于每一个k ,利用组合公式C(k,2)的答案就是平行四边行的个数

 

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

#define ll long long

struct Node{
int x,y;
}node[1010],mid[2010010];

int cmp(const Node &a,const Node &b){
if (a.x==b.x) return a.y<b.y;
else return a.x<b.x;
}

int f(int k){
if (k==1) return 0;
else
{
return k*(k-1)/2;
}
}

int main(){
int T,n;
scanf("%d",&T);
int cas=0;
while (T--) {

scanf("%d",&n);
for (int i=1; i<=n; i++) {
scanf("%d%d",&(node[i].x),&(node[i].y));
}

int num=0;
for (int i=1; i<=n; i++) {
for (int j=i+1; j<=n; j++) {

mid[num].x=node[i].x+node[j].x;
mid[num].y=node[i].y+node[j].y;
num++;
}
}
sort(mid,mid+num,cmp);
int k=1;
ll ans=0;
for (int i=0; i<num; i++) {
if (mid[i].x==mid[i+1].x && mid[i].y==mid[i+1].y)
k++;
else{
ans+=f(k);
k=1;
}
}
printf("%lld\n",ans);
// printf("Case %d: %lld\n",++cas,ans);

}
return 0;
}