Sumsets

Time Limit: 1000MS

 

Memory Limit: 65536K

Total Submissions: 9369

 

Accepted: 2564


Description




poj  Sumsets  2549  (二分+转换)_#define

Given S, a set of integers, find the largest d such that a + b + c = d where a, b, c, and d are distinct elements of S.


Input


Several S, each consisting of a line containing an integer 1 <= n <= 1000 indicating the number of elements in S, followed by the elements of S, one per line. Each element of S is a distinct integer between -536870912 and +536870911 inclusive. The last line of input contains 0.


Output


For each S, a single line containing d, or a single line containing "no solution".


Sample Input


52 3 5 7 12 5 2 16 64 256 1024 0


Sample Output


12no solution


//题意:


问所给的数中,是否存在四个数a,b,c,d,使得a+b+c=d;


若存在则输出d,否则输出弄solution;


转换 a+b==d-c;


#include<stdio.h>
#include<string.h>
#include<algorithm>
#define INF -0x3f3f3f3f
using namespace std;
int a[1010];
int main()
{
	int n;
	int i,j;
	while(scanf("%d",&n),n)
	{
		for(i=0;i<n;i++)
			scanf("%d",&a[i]);
		sort(a,a+n);
		int ans=INF;
		for(i=n-1;i>=0;i--)
		{
			for(j=n-1;j>=0;j--)
			{
				if(i==j)
					continue;
				int sum=a[i]-a[j];
				int l=0,r=j-1;
				while(l<r)
				{
					if(a[l]+a[r]==sum)
					{
						ans=a[i];
						break;
					}
					if(a[l]+a[r]>sum)
						r--;
					else
						l++;
				}
				if(ans!=INF)
					break;
			}
			if(ans!=INF)
				break;
		}
		if(ans==INF)
			printf("no solution\n");
		else
			printf("%d\n",ans);
	}
	return 0;
}