Expedition

                                                                           ​​POJ - 2431 ​

A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel every unit of distance it travels.

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1..100 units at each stop).

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000).

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all.

Input

* Line 1: A single integer, N

* Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop.

* Line N+2: Two space-separated integers, L and P

Output

* Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.

Sample Input

4
4 4
5 2
11 5
15 10
25 10

Sample Output

2

题目大意 : 汽车要行走 L 的路程,每走 1 距离消耗 1 单位的汽油,初始有 P单位油 ,一路上有 n 个加油站,可以获得相应的汽油,求最少要加多少次油可以到达终点。

思路 : 

如果认为,每经过一个加油站时,我们就获得一次在后面任何时候加油的权利,那么希望到达终点次数尽可能少,所以当燃料为0时再加油,并且选择加油量最大的加,维护一个优先队列q ,每次加油时,加队列最大的。

#include <iostream> 
#include <cstdio>
#include <algorithm>
#include <string>
#include <cstring>
#include <queue>
using namespace std ;
typedef long long LL ;
/*

*/
const int MAX = 100001 ;
const int inf = 0x3f3f3f3f ;
int a[MAX] ;
int b[MAX] ;
int L , p ;
priority_queue<int> q ; // 优先队列
// q可以理解为 维护一个加油权利的队列,每次经过一个加油站,
// 就获得一次加油的权利.
struct node { // 加油站
int x ; // 距离终点的距离
int fuel ; // 最多可以加的油量
};
int n ;
node s[MAX] ;
bool cmp(const node u , const node v ) {
if(u.x == v.x )
return u.fuel > v.fuel ;
return u.x < v.x ;
}
int main(){

cin >> n ;
for(int i = 0 ; i<n ; i++ ) { // 题目给的是加油站距离起始地
cin >>a[i] >>b[i] ;
}

cin >>L>> p ;
for(int i = 0 ; i<n ; i ++ ) {
s[i].x = L -a[i] ;
s[i].fuel = b[i] ;
}
s[n].x = L ; // 终点也相当于加油站
s[n].fuel = 0 ; // 终点不加油
sort(s,s+n+1,cmp) ; // 根据车到终点的距离排序
int ans = 0 ;
int t = p ; // 当前油量
int pos = 0 ; // 当前位置
for(int i = 0 ; i<n+1 ; i++) {
int d = s[i].x - pos ;

while(t<d) {// 只要当前油量不足,就可以使用以前获得的加油的权利
if(q.empty()) { // 如果没有权利,就
cout<<"-1"<<endl ;
return 0 ;
}
t+=q.top() ;
q.pop();
ans++ ;
}
t-=d;
pos = s[i].x ;
q.push(s[i].fuel) ;
}
cout<<ans <<endl;
return 0 ;
}