Description

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 
The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem. 

input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above. 

output

The output should contain the minimum time in minutes to complete the moving, one per line. 

Sample Input

3

4

10 20

30 40

50 60

70 80

2

1 3

2 200

3

10 100

20 80

30 50

Sample Output

10
20
30

题意

这层楼沿着走廊南北向的两边各有200个房间。最近,公司要做一次装修,需要在各个办公室之间搬运办公桌。 由于走廊狭窄,办公桌都很大,走廊里一次只能通过一张办公桌。必须制定计划提高搬运效率。 经理制定如下计划:一张办公桌从一个房间移到另一个房间最多用十分钟。当从房间i移动一张办公桌到房间j,两个办公室之间的走廊都会被占用。所以,每10分钟内,只要不是同一段走廊,都可以在房间之间移动办公桌。求最少搬运时间。

思路

就是求最少搬运次数,思路就是求楼道被占用的次数,当楼道被占用就计数+1,求出最少占用次数,然后把次数*10就是最少时间。

房间 1

房间 3

房间 5

房间 397

房间 399

走廊

房间 2

房间 4

房间 6

房间 398

房间 400

 

ac代码如下:

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
int main()
{
int n,sum,i,j,k;
int move[500];
scanf("%d",&n);
while(n--)
{
int from,to;
scanf("%d",&sum);
memset(move,0,sizeof(move));
for(i=0;i<sum;i++)
{
scanf("%d %d",&from,&to);
if(from%2==0)
from--;//开端是偶数的话等同于奇数开端
if(to%2==1)
to++;//末尾是奇数的话等同于偶数结尾
if(from>to)
swap(from,to);
for(j=from;j<=to;j++)//确保开端比末尾小
move[j]++;//记录每个搬运的占用次数
}
int count=0;
for(i=1;i<410;i++)
{
count=count>move[i]?count:move[i];//取占用次数。
}
printf("%d\n",count*10);
}
return 0;
}