Moving Tables


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 25967    Accepted Submission(s): 8608


Problem Description


The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 



Moving Tables(杭电1050)(贪心---区间不重叠问题)_java



The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving. 




Moving Tables(杭电1050)(贪心---区间不重叠问题)_java_02



For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.



 



Input


The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.


 



Output


The output should contain the minimum time in minutes to complete the moving, one per line.


 



Sample Input


3 4 10 20 30 40 50 60 70 80 2 1 3 2 200 3 10 100 20 80 30 50


 



Sample Output


10 20 30



这将作为2015年做的最后一道题。特此纪念~ 企盼2016。 心中要有一个梦,万一实现了呢!



题意:给你一些个房间,单数在上,双数在下,再给你一些搬桌子的初始房间和目的房间,要求在不重叠路线的情况下用时最少。


思路比较好想:先将房间给重新编号,比如上面单数房间号1,3其实和下面2,4是相同的房间(路线一样)~其他的也就是排序和


遍历,用标记数组记录已经搬走的桌子编号。最关键的一点是:搬桌子的初始房间号不一定是从小往大。但是路线还是是同一条,


不知道我说的明白不。。。比如说10 20,20 10虽然是不同的初始房间号,但还是需要走相同的路。




代码:



#include<stdio.h>
#include<algorithm>
using namespace std;
struct st
{
int l;
int r;
}s[202];
int cmp(st x,st y)
{
if(x.l!=y.l)
return x.l<y.l;
return x.r<y.r;
}
int main()
{
int test,i,j,k,n,a,b,ans;
int vis[202];
scanf("%d",&test);
while(test--)
{
scanf("%d",&n);
for(i=0;i<n;i++)
{
vis[i]=0;
scanf("%d%d",&a,&b);
if(a>b){
k=a;
a=b;
b=k;
}
if(a%2)
s[i].l=a/2+1;
else
s[i].l=a/2;
if(b%2)
s[i].r=b/2+1;
else
s[i].r=b/2;
}
ans=0;
sort(s,s+n,cmp);
for(i=0;i<n;i++)
{
if(!vis[i])
{
vis[i]=1;
k=i;
ans++;
for(j=i+1;j<n;j++)
{
if(!vis[j]&&s[j].l>s[k].r)
{
vis[j]=1;
k=j;
}
}
}
}
printf("%d\n",ans*10);
}
}