​Fractions Again?!​


Time Limit:3000MS

 

Memory Limit:Unknown

 

64bit IO Format:%lld & %llu


​Submit  ​​​​Status​

Description


分数拆分(Fractions Again?!)_UVa

It is easy to see that for every fraction in the form

(k > 0), we can always find two positive integers x and y, xy, such that:

.

Now our question is: can you write a program that counts how many such pairs of x and y there are for any given k?

​Input​

Input contains no more than 100 lines, each giving a value of k (0 < k ≤ 10000).

​Output​

For each k, output the number of corresponding (x, y) pairs, followed by a sorted list of the values of x and y, as shown in the sample output.

​Sample Input​


212


​Sample Output​

21/2 = 1/6 + 1/3
1/2 = 1/4 + 1/4
8
1/12 = 1/156 + 1/13
1/12 = 1/84 + 1/14
1/12 = 1/60 + 1/15
1/12 = 1/48 + 1/16
1/12 = 1/36 + 1/18
1/12 = 1/30 + 1/20
1/12 = 1/28 + 1/21
1/12 = 1/24 + 1/24

【分析】

       当 x 和 y 满足题意时,由于 x >= y,则 1/x <= 1/y,又因为1/k = 1/x + 1/y,所以 1/x = 1/k - 1/y <= 1/y 即 y <= 2k。通过枚举 y,算出 x 的值,那么x 和 y 便满足题意要求。 x = ( k * y) / (y - k),因为 x 为正整数,所以 y - k > 0 即 y > k。综上,y 枚举的范围为 [k + 1, 2k]。

用java语言编写程序,代码如下:


import java.io.BufferedInputStream;
import java.util.ArrayList;
import java.util.Scanner;

public class Main {
public static void main(String[] args) {
Scanner input = new Scanner(new BufferedInputStream(System.in));
while(input.hasNext()) {
int k = input.nextInt();

ArrayList<FA> list = new ArrayList<FA>();
for(int y = k + 1; y <= 2 * k; y++) {
if((k * y) % (y - k) == 0) {
int x = (k * y) / (y - k);
list.add(new FA(x, y));
}
}
int n = list.size();
System.out.println(n);
for(int i = 0; i < n; i++)
System.out.println("1/" + k + " = " + "1/" +
list.get(i).x + " + " + "1/" + list.get(i).y);
}
}

static class FA {
int x, y;
public FA(int x, int y) {
this.x = x;
this.y = y;
}
}
}