It is easy to see that for every fraction in the form 1
k
(k > 0), we can always find two positive integers
x and y, x ≥ y, such that:
1
k
=
1
x
+
1
y
Now our question is: can you write a program that counts how many such pairs of x and y there
are for any given k?
Input
Input contains no more than 100 lines, each giving a value of k (0 < k ≤ 10000).
Output
For each k, output the number of corresponding (x, y) pairs, followed by a sorted list of the values of
x and y, as shown in the sample output.
Sample Input
2
12
Sample Output
2
1/2 = 1/6 + 1/3
1/2 = 1/4 + 1/4
8
1/12 = 1/156 + 1/13
1/12 = 1/84 + 1/14
1/12 = 1/60 + 1/15
1/12 = 1/48 + 1/16
1/12 = 1/36 + 1/18
1/12 = 1/30 + 1/20

1/12 = 1/28 + 1/21

1/12 = 1/24 + 1/24

  

暴力求解,通过枚举所有的y值来找出满足条件的x

   由于x>=y,有1/x<=1/y,经化简可推出y<=2*k.

注意在保存x,y的数组,要开大一点。


第一次做的代码有些赘余:

#include<stdio.h>
int a[1000],b[1000];
int main()
{
int k,i,j,x,y,kase;
while(scanf("%d",&k)!=EOF)
{
int ans=0;
for(i=1;i<=2*k;i++)
{
j=i;
x=j*k;
y=j-k;
if(y>0)
{
kase=x/y;
if((kase*y==x)&&(kase>=j))
{
ans++;
a[ans]=kase;
b[ans]=j;
}
}
}
printf("%d\n",ans);
for(i=1;i<=ans;i++)
{
printf("1/%d = 1/%d + 1/%d\n",k,a[i],b[i]);
}
}
}


经改进后:

#include<stdio.h>
int a[1000],b[1000];//由于数组开小了,WA了好久。。。
int main()
{
int i,k;
while(scanf("%d",&k)==1)
{
int ans=0;
for(i=k+1;i<=2*k;i++)
{
if((i*k)%(i-k)==0)
{
ans++;
a[ans]=(i*k)/(i-k);
b[ans]=i;
}
}
printf("%d\n",ans);
for(i=1;i<=ans;i++)
{
printf("1/%d = 1/%d + 1/%d\n",k,a[i],b[i]);
}
}
}