Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems.

This problem requires that you write a program to compute the exact value of R n where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25. Input

The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

Output

The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.

Sample Input

95.123 12 0.4321 20 5.1234 15 6.7592 9 98.999 10 1.0100 12

Sample Output

548815620517731830194541.899025343415715973535967221869852721 .00000005148554641076956121994511276767154838481760200726351203835429763013462401 43992025569.928573701266488041146654993318703707511666295476720493953024 29448126.764121021618164430206909037173276672 90429072743629540498.107596019456651774561044010001 1.126825030131969720661201




题意:把一个小数(最多5个数字+1个小数点)n次方,精确输出,删去前导0.



高精度。省去小数点来处理。由于n不是很大,直接暴力即可。



被两个坑点坑了好久,交了好多次。



1.输入的小数不一定输入满6格



2. 0.0的任意次方都输出0




#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<iostream>
#include<queue>
#include<map>
#define ll long long
#define N 500
using namespace std;
int a[N],b[N],c[N];
int main(){
char ts[10];
int j,k;bool flag;
int alen,blen,n;
int len;
while (~scanf("%s %d",ts,&n)){
n--;
len=strlen(ts);
j=len; flag=0;
int nn=n+1;
for (int i=0;i<len;i++)
if (ts[i]=='.') flag=1;
if (flag)
for (int i=len-1;i>=0;i--)
if (ts[i]-48){
j=i+1; break;
}
if (ts[j-1]=='.') j--,flag=0;
alen=0;
for (int i=j-1;i>=0;i--)
if (ts[i]=='.') flag=1,k=i;
else a[++alen]=ts[i]-48;
for (int i=1;i<=alen;i++) b[i]=a[i];
blen=alen;
if (alen==1 && a[1]==0){
printf("0\n");
continue;
}
while (n--){
memset(c,0,sizeof(c));
for (int i=1;i<=alen;i++)
for (int j=1;j<=blen;j++){
c[i+j-1]+=a[i]*b[j];
c[i+j]+=c[i+j-1]/10;
c[i+j-1]%=10;
}
if (c[alen+blen]) alen=alen+blen;
else alen=alen+blen-1;
for (int i=1;i<=alen;i++) a[i]=c[i];
}
if (flag) k=(j-1-k)*nn;
int start=alen;
while (!a[start]) start--;
if (!flag) k=start;
for (int i=start;i>k;i--) printf("%d",a[i]);
if (flag) printf(".");
for (int i=k;i>0;i--) printf("%d",a[i]);
printf("\n");
}
return 0;
}