Exponentiation


Time Limit: 500MS

 

Memory Limit: 10000K

Total Submissions: 154884

 

Accepted: 37736


Description


Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems. 

This problem requires that you write a program to compute the exact value of R n where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.


Input


The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.


Output


The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.


Sample Input


95.123 12 0.4321 20 5.1234 15 6.7592 9 98.999 10 1.0100 12


Sample Output


548815620517731830194541.89902534341571597353596722186985272

.00000005148554641076956121994511276767154838481760200726351203835429763013462401 43992025569.928573701

266488041146654993318703707511666295476720493953024 29448126.

764121021618164430206909037173276672 90429072

743629540498.107596019456651774561044010001 1

.126825030131969720661201


Hint


If you don't know how to determine wheather encounted the end of input: 
s is a string and  n is an integer 




AC:用C++写的话太麻烦了,直接用java的大数。。。。。



import java.io.PrintWriter;
import java.math.BigDecimal;
import java.util.Scanner;

public class Main {
static Scanner cin = new Scanner(System.in);
static PrintWriter cout = new PrintWriter(System.out, true);

public static void main(String[] args)
{
BigDecimal a,c;
int b;
while (cin.hasNext())
{
a = cin.nextBigDecimal();
b = cin.nextInt();
c = a.pow(b);
String ans = c.toPlainString();
if (ans.contains(".") == false)
{
cout.println(ans);
}
else
{
int x = 0, y = ans.length() - 1;
while (ans.charAt(x) == '0') x++;
while (ans.charAt(y) == '0') y--;
if (ans.charAt(y) != '.') y++;
cout.println(ans.substring(x, y));
}

}
}
}