1098 Insertion or Heap Sort (25 point(s))

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Heap sort divides its input into a sorted and an unsorted region, and it iteratively shrinks the unsorted region by extracting the largest element and moving that to the sorted region. it involves the use of a heap data structure rather than a linear-time search to find the maximum.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Heap Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resulting sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 6 0
6 4 5 1 0 3 2 7 8 9

Sample Output 2:

Heap Sort
5 4 3 1 0 2 6 7 8 9

经验总结:

这一题也是考验基本功......弄清楚堆排序的一趟到底是怎样的———将堆顶与倒数第i位交换,然后在1~i-1范围内对堆顶进行一次向下调整,这才是完整的一趟堆排序,必须使用基本操作实现,而不是利用优先级队列直接排序,那样得不到中间状态的序列。就这么多啦~

AC代码

#include <cstdio>
#include <cmath>
#include <vector>
#include <algorithm>
using namespace std;
const int maxn=110;
int ori[maxn],out[maxn],interval[maxn],n;
bool cmp()
{
for(int i=1;i<=n;++i)
if(out[i]!=interval[i])
return false;
return true;
}
void cpy()
{
for(int i=1;i<=n;++i)
out[i]=ori[i];
}
bool insert()
{
cpy();
int f=0;
for(int i=2;i<=n;++i)
{
int temp=out[i];
int j=i;
while(j>=2&&out[j-1]>temp)
{
out[j]=out[j-1];
--j;
}
out[j]=temp;
if(f==1)
break;
if(cmp())
f=1;
}
return f;
}
void downadjust(int low,int high)
{
int i=low,j=i*2;
while(j<=high)
{
if(j+1<=high&&out[j+1]>out[j])
++j;
if(out[j]>out[i])
{
swap(out[j],out[i]);
i=j;
j=j*2;
}
else
break;
}
}
bool heapsort()
{
cpy();
for(int i=n/2;i>=1;--i)
downadjust(i,n);
int f=0;
for(int i=n;i>1;--i)
{
swap(out[1],out[i]);
downadjust(1,i-1);
if(f==1)
break;
if(cmp())
f=1;
}
return f;
}
void print()
{
for(int i=1;i<=n;++i)
printf("%d%c",out[i],i!=n?' ':'\n');
}
int main()
{
scanf("%d",&n);
for(int i=1;i<=n;++i)
scanf("%d",&ori[i]);
for(int i=1;i<=n;++i)
scanf("%d",&interval[i]);
if(insert())
{
printf("Insertion Sort\n");
print();
}
else
{
printf("Heap Sort\n");
heapsort();
print();
}
return 0;
}