1140.Look-and-say Sequence(20)

 jnxxhzz 分类: ​​PAT​​  2018-03-19 06:15:48

 所属标签 ​​PAT ​​​​甲级​



1140. Look-and-say Sequence (20)

Look-and-say sequence is a sequence of integers as the following:

D, D1, D111, D113, D11231, D112213111, …
where D is in [0, 9] except 1. The (n+1)st number is a kind of description of the nth number. For example, the 2nd number means that there is one D in the 1st number, and hence it is D1; the 2nd number consists of one D (corresponding to D1) and one 1 (corresponding to 11), therefore the 3rd number is D111; or since the 4th number is D113, it consists of one D, two 1’s, and one 3, so the next number must be D11231. This definition works for D = 1 as well. Now you are supposed to calculate the Nth number in a look-and-say sequence of a given digit D.

Input Specification:

Each input file contains one test case, which gives D (in [0, 9]) and a positive integer N (<=40), separated by a space.

Output Specification:

Print in a line the Nth number in a look-and-say sequence of D.

【数据】

Sample Input:
1 8

Sample Output:
1123123111

【分析】

据说卡了很多人的题目….的确一下子看不懂题目….题意大概是这样的
先给出一个数字D开始
然后每次把连续相同的数字合并成 [i][number]的形式
也就是111会变成13,22会变成22,55变成52这样

【代码】

#include <bits/stdc++.h>
using namespace std;
int a[100000];
int b[100000];
int all;
void judge()
{
int len = 0;
int i=0;
while (i<all)
{
b[len++] = a[i];
int x = 1;
while (a[i+1] == a[i]) x++,i++;
b[len++] = x;
i++;
}
for (int i=0;i<len;i++)
a[i] = b[i];
all = len;
//for (int i=0;i<all;i++) printf("%d",a[i]);
//puts("");
}
int main()
{
int D,n;scanf("%d%d",&D,&n);
all = 1;
a[0] = D;n--;
while (n--)
judge();
for (int i=0;i<all;i++) printf("%d",a[i]);
return 0;
}