1140 Look-and-say Sequence (20 point(s))

Look-and-say sequence is a sequence of integers as the following:

D, D1, D111, D113, D11231, D112213111, ...

where ​​D​​​ is in [0, 9] except 1. The (n+1)st number is a kind of description of the nth number. For example, the 2nd number means that there is one ​​D​​​ in the 1st number, and hence it is ​​D1​​​; the 2nd number consists of one ​​D​​​ (corresponding to ​​D1​​​) and one 1 (corresponding to 11), therefore the 3rd number is ​​D111​​​; or since the 4th number is ​​D113​​​, it consists of one ​​D​​​, two 1's, and one 3, so the next number must be ​​D11231​​​. This definition works for ​​D​​​ = 1 as well. Now you are supposed to calculate the Nth number in a look-and-say sequence of a given digit ​​D​​.

Input Specification:

Each input file contains one test case, which gives ​​D​​ (in [0, 9]) and a positive integer N (≤ 40), separated by a space.

Output Specification:

Print in a line the Nth number in a look-and-say sequence of ​​D​​.

Sample Input:

1 8

Sample Output:

1123123111

经验总结:

这一题,由于不知道40次之后会有多大,所以使用string来进行操作比较稳妥,难度不大,就不多说啦~

AC代码

#include <cstdio>
#include <string>
#include <iostream>
using namespace std;
int n;

int main()
{
string str,temp;
cin>>str>>n;
for(int i=0;i<n-1;++i)
{
temp.clear();
char str1[20];
int num=1;
for(int j=1;j<str.size();++j)
{
if(str[j]==str[j-1])
++num;
else
{
temp+=str[j-1];
sprintf(str1,"%d",num);
temp+=str1;
num=1;
}
}
temp+=str[str.size()-1];
sprintf(str1,"%d",num);
temp+=str1;
str=temp;
}
printf("%s",str.c_str());
return 0;
}