http://poj.org/problem?id=2488
Description
Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one
direction and one square perpendicular to this. The world of a knight is
the chessboard he is living on. Our knight lives on a chessboard that
has a smaller area than a regular 8 * 8 board, but it is still
rectangular. Can you help this adventurous knight to make travel plans?
Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
Output
The output for every scenario begins with a line containing "Scenario #i:",
where i is the number of the scenario starting at 1. Then print a
single line containing the lexicographically first path that visits all
squares of the chessboard with knight moves followed by an empty line.
The path should be given on a single line by concatenating the names of
the visited squares. Each square name consists of a capital letter
followed by a number.
If no such path exist, you should output impossible on a single line.
Sample Input
3
1 1
2 3
4 3
Sample Output
Scenario #1:
A1
Scenario #2:
impossible
Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4
题目大意:
给出国际象棋的的一个棋盘,里面有一个马,给出所在棋盘的长和宽,问从任意一点开始,能否不重复的走遍棋盘上的每一点,若能就输出一个字符串,其中字母代表行,数字代表列(按字典序搜索),不能就输出impossible
解题思路:
很明显可以用DFS暴力搜索,但是要注意的是,骑士在搜索的时候按字典序的方向搜索。
题目解析:
一直没读懂题,做出来的答案一直和样例不同,后来看题解,说是要按字典序搜索,然后又是N遍WA,(只能说dfs自己学的很渣,递归一会就
递晕了),然后没敢深入思考,别人的代码,都是指dfs了一遍,即dfs(1,1,1),我不知道为什么,只好枚举所有结果,综合来说,算是一道
水题吧,只要知道按字典序搜索就好了。
#include <stdio.h>
#include <iostream>
#include <string.h>
#include <stdlib.h>
using namespace std;
int jx[8]= {-2,-2,-1,-1,1,1,2,2};
int jy[8]= {-1,1,-2,2,-2,2,-1,1};
int m,n,v[28][28],flag;
char f[28*28];
int g[28*28];
void pu()
{
for(int i=1; i<=n*m; i++)
{
printf("%c%d",f[i],g[i]);
}
printf("\n");
}
void dfs(int x,int y,int ans)
{
int tx,ty;
if(ans==n*m)
{
f[ans]=x+'A'-1;
g[ans]=y;
flag=1;
return ;
}
for(int i=0; i<8; i++)
{
tx=x+jx[i];
ty=y+jy[i];
if(tx>=1&&tx<=n&&ty>=1&&ty<=m&&v[tx][ty]==0)
{
v[tx][ty]=1;
f[ans+1]=tx+'A'-1;
g[ans+1]=ty;
dfs(tx,ty,ans+1);
if(flag==1)
return ;
v[tx][ty]=0;
}
}
return ;
}
int main()
{
int T;
scanf("%d",&T);
for(int z=1; z<=T; z++)
{
flag=0;
scanf("%d%d",&m,&n);
printf("Scenario #%d:\n",z);
for(int i=1; i<=n; i++)
{
for(int j=1; j<=m; j++)
{
memset(v,0,sizeof(v));
v[i][j]=1;
f[1]=i-1+'A';
g[1]=j;
dfs(i,j,1);
if(flag==1)
{
pu();
break;
}
}
if(flag==1) break;
}
if(flag==0) printf("impossible\n");
printf("\n");
}
return 0;
}