A Knight's Journey
Time Limit: 1000MS | | Memory Limit: 65536K |
Total Submissions: 32972 | | Accepted: 11239 |
Description
Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?
Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.
Sample Input
31 1 2 3 4 3
Sample Output
Scenario #1:A1 Scenario #2: impossible Scenario #3: A1B3C1A2B4C2A3B1C3A4B2C4
Source
TUD Programming Contest 2005, Darmstadt, Germany
#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
using namespace std;
struct node
{
int x;
int y;
}q[10010];
int jx[] = {-2,-2,-1,-1,1,1,2,2};
int jy[] = {-1,1,-2,2,-2,2,-1,1};
int v[51][51];
int n,m;
int sum;
int z;
int flag;
void DFS(int x,int y)
{
if(z>sum)
{
flag = 1;
return ;
}
for(int i=0;i<8;i++)
{
int xx = x + jx[i];
int yy = y + jy[i];
if(xx>=1 && xx<=m && yy>=1 && yy<=n && v[xx][yy] == 0)
{
// printf("xx = %d yy = %d v[%d][%d] = %d z = %d\n",xx,yy,xx,yy,v[xx][yy],z);
v[xx][yy] = 1;
q[z].x = xx;
q[z].y = yy;
z++;
DFS(xx,yy);
if(z > sum)
{
flag = 1;
return ;
}
z--;
v[xx][yy] = 0;
}
}
}
int main()
{
int T;
int k = 0;
scanf("%d",&T);
while(T--)
{
k++;
scanf("%d%d",&n,&m);
sum = n*m;
flag = 0;
memset(v,0,sizeof(v));
q[1].x = 1;
q[1].y = 1;
v[1][1] = 1;
z = 2;
DFS(1,1);
//printf("flag = %d\n",flag);
printf("Scenario #%d:\n",k);
if(flag == 0)
{
printf("impossible\n\n");
continue;
}
for(int i=1;i<=sum;i++)
{
printf("%c%d",q[i].x+'A'-1,q[i].y);
}
printf("\n\n");
}
return 0;
}