Elevator


Problem Description


The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.


For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.


Input

There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.


Output

Print the total time on a single line for each test case.


Sample Input

1 2

3 2 3 1

0


Sample Output

17

41

题目大意:

我们城里最高的建筑物只有一个电梯。请求列表是由n个正数组成的。数字表示电梯在哪个楼层按指定的顺序停车。电梯上一层要6秒,下一层楼要4秒。电梯每站停留5秒。

对于给定的请求列表,您将计算用于满足列表中请求的总时间。电梯一开始就在零层,当满足要求时不必返回地面。

有多个测试用例。每个案例包含一个正整数n,然后是n个正数。输入中的所有数字都小于100。带有n=0的测试用例表示输入的结束。此测试用例不被处理。

AC代码:



#include<stdio.h>
int main()
{
int n;
while(scanf("%d",&n)!=EOF&&n&&n<100)
{
int a[n];
int i;
for(i=0;i<n;i++)
{
scanf("%d",&a[i]);
if(a[i]>=100)
return 0;
}
int sum;
sum=a[0]*6+5;
for(i=0;i<n-1;i++)
{
if(a[i+1]>a[i]) sum+=(a[i+1]-a[i])*6+5;
if(a[i+1]<a[i]) sum+=(a[i]-a[i+1])*4+5;
if(a[i+1]==a[i]) sum+=5;
}
printf("%d\n",sum);
}
return 0;
}