1008 Elevator (20 point(s))

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41

Experiential Summing-up

This problem is so easy, so I don't said more about it.~

 (The purpose of using English to portray my solution is that to exercise the ability of my expression of English and accommodate PAT advanced level's style.We can make progress together by reading and comprehending it. Please forgive my basic grammar's and word's error. Of course, I would appreciated it if you can point out my grammar's and word's error in comment section.( •̀∀•́ ) Furthermore, Big Lao please don't laugh at me because I just a English beginner settle for CET6    _(:з」∠)_  )

Accepted Code 

#include <cstdio>

int main()
{
int n,t;
scanf("%d",&n);
int total=0,pos=0;
for(int i=0;i<n;++i)
{
scanf("%d",&t);
if(t>pos)
{
total+=(t-pos)*6;
}
else
{
total+=(pos-t)*4;
}
pos=t;
total+=5;
}
printf("%d\n",total);
return 0;
}